Om du tar bort serviceavtal eller SLA-objekt visas ett fel i Enhetligt gränssnitt under en lösningsuppgradering eller manuell borttagning
Den här artikeln innehåller en lösning på problemet där borttagning av serviceavtal (SLA) eller SLA-objekt visar ett felmeddelande i Enhetligt gränssnitt under en lösningsuppgradering eller manuell borttagning.
Symptom
När du försöker ta bort serviceavtal eller SLA-objekt under en lösningsuppgradering eller manuell borttagning uppstår något av följande felmeddelanden:
Det objekt som du försökte ta bort är associerat med ett annat objekt och kan inte tas bort.
SLAItem-borttagningsåtgärden påträffade vissa fel. Processen ingår i en hanterad lösning och kan inte tas bort individuellt. Avinstallera den överordnade lösningen för att ta bort processen. Mer information finns i loggen.
Orsak
Det första felmeddelandet uppstår eftersom relationen mellan SLA-objektet och SLA KPI-instanserna i Unified Interface SLA är inställd på "Begränsa till Ta bort". Det andra felmeddelandet inträffar eftersom processer som ingår i en hanterad lösning inte kan tas bort. När du försöker ta bort ett SLA manuellt, som är en del av en hanterad lösning och har konfigurerat flöden, visas felmeddelandet.
Lösning 1
I stället för att ta bort SLA inaktiverar du SLA-serviceavtalet i organisationen. Om det är en del av en hanterad lösning utför du följande steg:
- Inaktivera SLA i källinstansen och lägg till det i lösningen.
- Inaktivera samma serviceavtal i målinstansen och tillämpa sedan lösningsuppgradering.
Lösning 2
Du kan först ta bort alla SLA-relaterade entitetsposter och SLA KPI-instanser manuellt och sedan ta bort serviceavtalet. Här är stegen:
- I din organisation går du till Avancerad sökning, söker efter SLA KPI-instanser och väljer sedan SLAItem.
- Välj Resultat. SLA KPI-instanserna visas i listan.
- Markera de nödvändiga SLA KPI-instanserna och välj sedan Ta bort SLAKPIInstances. Detta annullerar även SLA KPI-instanserna för de relaterade posterna.
Även efter borttagning av referensposterna, om felmeddelandet "SLAItem delete operation encountered some errors. Processen är en del av en hanterad lösning och kan inte tas bort individuellt. Avinstallera den överordnade lösningen för att ta bort processen. Se loggen för mer information" visar och tillämpa sedan lösningsuppgradering med serviceavtalet borttaget från uppgraderingslösningen.
Lösning 3
Om ovanstående lösning inte fungerar kontaktar du Microsoft Support för att begära att SLA- eller SLA-objekten tas bort.