Dela via


En kortbetalning misslyckas på grund av en korttyp som inte stöds

Den här artikeln hjälper dig att lösa felet "Korttypen är inte en godkänd betalningsform" som inträffar vid bearbetning av kredit- eller debetkortstransaktioner i Microsoft Dynamics 365 Commerce.

Symptom

En kortbetalning (eller presentkort) misslyckas med följande felmeddelande på försäljningsstället (POS):

Korttypen är inte en godkänd betalningsform. Använd ett annat betalkort och försök sedan igen.

Du kan också se följande felmeddelande i händelseloggen:

Korttypen med ID :t "Okänt" hittades inte.

Obs!

Kortbetalningen har godkänts innan du får felmeddelandet. När felmeddelandet har inträffat annulleras kortbetalningen av betalningstjänsten.

Orsak

De korttyper som konfigurerats för kanalens betalningsmetod matchar inte betalningsinformationen som returneras av betalningsanslutningsappen.

Korttyper matchas av en kombination av intervall, korttyps-ID (till exempel kredit eller debet) och posttyp (Swipe eller Manual).

Lösning 1

Lös problemet genom att kontrollera att korttyperna är korrekt konfigurerade för anbudstyp och kanal.

  • I händelseloggen på POS - eller POS-klientloggen i Microsoft Dynamics Lifecycle Services (LCS) finns följande händelsenamn för att se vilka korttypsvärden som används.

    • posPaymentCardTypeFilterByBinRangeIsDebitOrCredit

      Den här händelsen anger om betalningsprocessorn fick korttypen som kredit-, debet- eller presentkort. Om värdet inte är som förväntat kanske finansieringskällan inte anges eller skickas korrekt.

    • posPaymentCardTypeFilterByBinRangeIsSwipe

      Den här händelsen anger om användaren har valt att svepa eller manuellt ange kortet via POS. Om korttypen med ett matchande intervall inte tillåter en manuell post, men kortet har angetts via en sveppost, kan detta inte resultera i matchande korttyper.

    Obs!

    POS söker efter ett matchande intervall baserat på korttypen som returneras av betalningsprocessorn eller anslutningsappen.

    • Om korttypen är "Kreditkort" söker POS efter alla korttyper som har angetts för butiken som "internationellt kreditkort" och letar efter en intervallmatchning inom dessa korttyper.
    • Om korttypen är "Debetkort" söker POS efter alla korttyper som angetts för butiken som "Internationellt debetkort" och matchar inom dessa intervall.
    • Om betalningsanslutningsappen inte anger någon korttyp betraktar POS det som standard som ett kreditkort och söker efter en matchning inom typen "Internationellt kreditkort".
  • Gå till Retail and Commerce Channel SetupPayment methods>Card types (Korttyper för återförsäljar- ochhandelskanalinstallation>> i Commerce-huvudkontoret).

    • Kontrollera om det finns ett kortmärke. Lägg till ett kortmärke om det saknas.
    • Kontrollera om korttypen (internationellt kreditkort eller internationellt debetkort) är korrekt tilldelad till varumärket.
    • Välj Kortnummer i verktygsfältet och se till att ett intervall är inställt för att täcka det ouppnåeliga kortnumret.

    Obs!

    Om ett kredit- eller debetkort har angetts korrekt men du fortfarande får ett fel kan felet orsakas av att betalningsanslutningsappen returnerar fel korttyps-ID. Betalningsanslutningsappen returnerar till exempel typen "Debetkort", men endast typen "Kreditkort" anges i Commerce-huvudkontoret. I det här fallet skapar du en korttyp med samma intervall för både kredit- och debetkort.

  • I Commerce-huvudkontoret går du till den kanal eller det butiksformulär som har problemet.

    1. Välj Konfigurera>betalningsmetoder och välj den betalningsmetod som används av korten.
    2. Välj Konfiguration av elektronisk betalning och lägg till både kredit- och debetkortstyper i betalningsmetoden.

Om några ändringar av korttyper eller betalningsmetod har gjorts kör du CDX 1090-jobbet och kontrollerar att dess status visas som tillämpad.

Lösning 2

Lös problemet genom att kontrollera den fundingSource identifierare som angetts i Adyen.

I Dynamics 365 Betalningsanslutning för Adyen anges en korttyp baserat på identifieraren fundingSource i Adyen-auktoriseringssvaret. Om identifieraren fundingSource inte anges av Adyen i auktoriseringssvar anges inte en korttyp i anslutningsappen. Pos är dock som standard "kredit" när du letar efter intervall.

Om du har problem med "intervallintervall saknas", men du inte har ändrat inställningarna för intervall för korttyp nyligen, kan problemet bero på någon av följande orsaker:

  1. En nyligen genomförd uppgradering av den inbyggda programvaran i Adyen har börjat skicka identifieraren fundingSource .
  2. Identifieraren fundingSource har nyligen aktiverats i Adyen-portalen.
  3. Intervallintervallet har inte angetts för den specifika kort- eller korttypen.

I version 1.42.4 av den inbyggda programvaran i Adyen och tidigare versioner är identifieraren fundingSource inte obligatorisk och Adyen använde inte för att skicka den. I version 1.44 av den inbyggda programvaran i Adyen och senare versioner skickas finansieringskällan tillbaka i auktoriseringssvaret som ett obligatoriskt fält för en POS-terminal och egenskapen styrs inte av någon konfiguration i Adyen-portalen.

Följ dessa steg för att aktivera eller inaktivera finansieringskällan i Adyen-portalen:

  1. Logga in på Adyen-portalen.
  2. I det övre navigeringsfältet väljer du Konto-API>:er>Ytterligare datainställningar.
  3. Rulla ned för att hitta inställningen Finansieringskälla , aktivera eller inaktivera den och spara sedan ändringarna.

Mer information

Mer information finns i Konfiguration av betalningsmetoder.

Ansvarsfriskrivning för information från tredje part

De produkter från andra tillverkare som diskuteras i denna artikel tillverkas oberoende av Microsoft. Produkternas funktion eller tillförlitlighet kan därför inte garanteras.