Felet "Det gick inte att aktivera replikeringen" inträffar i installationsprogrammet för molnmigrering
Den här artikeln löser ett felmeddelande som inträffar när du kör guiden för installation av molnmigrering i Business Central.
Symptom
När du kör installationsguiden för molnmigrering under datamigreringsprocessen från lokalt till Business Central online får du följande felmeddelande:
Det gick inte att aktivera replikeringen. Kontrollera att integreringskörningen har anslutits och försök igen.
Orsak
Det kan finnas flera orsaker till felmeddelandet. Men den vanligaste orsaken är ett matchningsfel mellan den lokala versionen och onlineversionerna av Business Central och produkttypen som valts i installationsguiden för molnmigrering.
Åtgärd
Kör installationsprogrammet för molnmigrering och se till att produkttypen är konsekvent med dina lokala och onlineversioner när du kommer till sidan Välj produkt. Business Central-versionsnummer bör ha formatet Major.Minor.Revision.Build , till exempel 20.1.12345.67890.
- Om de lokala och onlinebaserade huvudversionerna är desamma, till exempel 20.1 för lokalt och 20.3 för online väljer du Aktuell version för Dynamics Business Central.
- Om de lokala och onlinebaserade huvudversionerna skiljer sig åt, till exempel 14.3 för lokalt och 20.3 för online väljer du Tidigare versioner av Dynamics Business Central.
Du kan köra följande SQL-fråga för att verifiera att den lokala databasen innehåller rätt versionsnummer:
SELECT [applicationversion]
FROM [$ndo$tenantdatabaseproperty]