Tidsgräns för en aktivitet i Business Central-molnmigrering
Den här artikeln innehåller felsökningssteg för ett problem där en aktivitet överskrider tidsgränsen under molnmigreringen i Business Central.
Symptom
En aktivitet överskrider tidsgränsen under molnmigreringen i Business Central.
Orsak
Om en aktivitet överskrider tidsgränsen under molnmigreringskonfigurationen kan det inträffa antingen på grund av att Integration Runtime inte kunde upprätta en anslutning till SQL Server eller på grund av indexdefragmentering i stora lokala databaser. Om tidsgränsen överskrids under en migreringskörning är orsaken troligen en svag eller upptagen lokal SQL Server.
Åtgärd
Om SQL-anslutningen är permanent bruten kontrollerar du om .NET 4.72 eller senare körs på värden för integrationskörningen.
Kontrollera andra krav för integrationskörning på sidan Azure Data Factory .
För problem med databasprestanda rekommenderar vi att du uppdaterar statistik och omorganiserar index i den lokala databasen innan du konfigurerar molnmigrering.
Om du vill uppdatera statistiken kör du följande fråga (till exempel i Microsoft SQL Management Studio som är ansluten till den lokala databasen):
EXEC sp_updatestats;
Kör följande fråga för att ordna om index:
EXEC sys.sp_MSforeachtable 'ALTER INDEX ALL ON ? REORGANIZE'