Fel 0xC004FD01 eller 0xC004FD02 när du aktiverar en virtuell Azure Windows-dator
Gäller för: ✔️ Virtuella Windows-datorer
Den här artikeln innehåller en lösning på felet 0xC004FD01 eller 0xC004FD02 som inträffar när du försöker aktivera en virtuell Azure Windows-dator (VM).
Symptom
När du försöker aktivera en virtuell Azure Windows-dator får du ett felmeddelande som liknar följande exempel:
Kod:
0xC004FD01
Beskrivning:
Windows körs inte på en Microsoft Hyper-V-virtualiseringsplattform som stöds.
Kod:
0xC004FD02
Beskrivning:
Windows är inte aktiverat på värddatorn. Kontakta systemadministratören.
Orsak
Den virtuella datorn är konfigurerad för att aktiveras via automatisk aktivering av virtuella datorer (AVMA), som inte stöds i Azure.
Det här problemet kan inträffa i något av följande scenarier:
Den virtuella datorn körs ursprungligen lokalt eller i en annan molnmiljö och migreras sedan till Azure.
En AVMA-aktiveringsnyckel konfigureras på den virtuella datorn när den har distribuerats till Azure.
Bekräfta AVMA-konfigurationen genom att öppna kommandotolken som administratör och köra slmgr /dlv
kommandot . Efter kommandokörningen visas ett Fönster för Windows-skriptvärd :
Texten "VIRTUAL_MACHINE_ACTIVATION" på raden Beskrivning innebär att AVMA-aktiveringsmetoden används.
Lösning
Lös problemet genom att ändra aktiveringsmetoden från AVMA till nyckelhanteringstjänst (KMS) genom att uppdatera aktiveringsnyckeln. KMS är en aktiveringsmetod som stöds i Azure. Gör detta genom att köra följande kommando:
slmgr /ipk <product key>
Kommentar
Ersätt <product key>
med de 25 bokstäver eller siffror som tillhör den produktnyckel som du ska använda. Om du använder KMS visas dessa nycklar i KMS-nycklar.
När nyckeln har angetts visas meddelandet ”Installationen genomfördes”. Nu bör aktiveringen ske automatiskt. Du kan också utlösa aktiveringen manuellt genom att köra följande kommandon:
slmgr /ckms
slmgr /skms azkms.core.windows.net:1688
slmgr /ato
Dessa kommandon begär aktivering av Azure KMS-värden.
Kontakta oss för att få hjälp
Om du har frågor eller behöver hjälp skapar du en supportförfrågan eller frågar Azure community support. Du kan också skicka produktfeedback till Azure-feedbackcommunityn.