Dela via


Felkod 0x80090016 – Nyckeluppsättningen finns inte i loggboken eller agentloggarna

Kommentar

Log Analytics-agenten, även kallad Microsoft Monitoring Agent (MMA), dras tillbaka i augusti 2024. Därför uppdateras Defender för servrar och Defender för SQL-servrar på datorplaner i Microsoft Defender för molnet, och funktioner som förlitar sig på Log Analytics-agenten kommer att göras om. Mer information finns i Förbereda för tillbakadragning av Log Analytics-agenten.

Den här artikeln beskriver hur du löser felkoden 0x80090016 – "Nyckeluppsättningen finns inte" när du försöker ansluta till loggboken eller agentloggarna.

Symptom

När du försöker ansluta till en Log Analytics-arbetsyta via Microsoft Monitoring Agent (MMA) misslyckas anslutningen och någon av följande felposter loggas i Loggboken för Operations Manager:

Event ID:      7022 
Description:   The Health Service has downloaded secure configuration for management
               group AOI-00000000-0000-0000-0000-000000000000, and processing the 
               configuration failed with error code Keyset does not exist(0x80090016). 
Event ID:      3009  
Description:   Loading the private key for the client authentication certificate for
               service "Log Analytics - ed4Customer-WorkspaceID" failed with error 
               "Keyset does not exist" (0x80090016). Connections to the service may
               be made without authentication. This can cause failures if the service
               requires the agent to be authenticated. The agent will continue to 
               periodically retry loading the authentication configuration.

Orsak

Servern klonades från en gyllene avbildning (även kallad en huvudbild) som redan hade Windows Log Analytics-agenten installerad och konfigurerad. Anslutningen misslyckas eftersom certifikaten innehåller namnet på den ursprungliga servern som klonades i stället för namnet som för närvarande används av Windows. (Obs! Kloning av en dator som har Log Analytics-agenten redan konfigurerad stöds inte.)

Lösning

Lös dessa fel genom att rensa och uppdatera MMA-certifikaten enligt följande:

  1. Öppna snapin-modulen Tjänster genom att välja Start, ange services.msc och sedan trycka på Retur.

  2. Om du vill stoppa tjänsten väljer du Microsoft Monitoring Agent och väljer sedan ikonen Stoppa tjänst .

  3. Om du vill öppna Microsoft Management Console (MMC) väljer du Start, anger mmc.exe och trycker sedan på Retur.

  4. Om du vill lägga till snapin-modulen Certifikat väljer du Lägg>till/ta bort snapin-certifikat>>Lägg till>datorkonto>Nästa>lokala dator>Slutför>OK.

  5. Om du vill visa befintliga MMA-certifikat i MMC går du till Certifikat microsoft monitoring agent certificates (Certifikat>för Microsoft Monitoring Agent>).

  6. Vi rekommenderar att du exporterar varje certifikat så att du har en säkerhetskopia för säkerhet och granskning. För att göra detta följer du stegen nedan:

    1. Välj och högerklicka på varje listat certifikat individuellt och välj sedan Alla aktiviteter>Exportera>nästa>nej, exportera inte den privata nyckeln.

    2. På sidan Exportera filformat väljer du Base-64-kodad X.509 (. CER)>Nästa.

    3. På sidan Fil att exportera i fältet Filnamn anger du namnet på certifikatfilen och bläddrar sedan till den plats där du vill exportera certifikatet. Välj sedan Spara>nästa>slut.

  7. När du har exporterat säkerhetskopior av de certifikat som visas i mittenfönstret enligt beskrivningen i steg 6 tar du bort certifikaten från MMC. Håll konsolen öppen.

  8. I snapin-modulen Tjänster väljer du Microsoft Monitoring Agent och sedan ikonen Starta tjänst för att starta om den.

  9. Vänta en minut. Välj sedan snapin-modulen Certifikat i MMC och välj ikonen Uppdatera eller F5 för att uppdatera. Du bör se nya certifikat.

Observera agenten, händelseloggarna och Log Analytics-arbetsytan för att avgöra om de här stegen löste problemet.

Mer information

Installation av Microsoft Monitoring Agent

Översikt över Log Analytics Agent: installationsalternativ

Kontakta oss för att få hjälp

Om du har frågor eller behöver hjälp skapar du en supportförfrågan eller frågar Azure community support. Du kan också skicka produktfeedback till Azure-feedbackcommunityn.