Felsöka felkoden SubscriptionRequestsThrottled (429)
I den här artikeln beskrivs hur du identifierar och löser felet SubscriptionRequestsThrottled
(status 429) som inträffar när du försöker skapa och distribuera ett AKS-kluster (Microsoft Azure Kubernetes Service).
Symptom
När du försöker skapa ett AKS-kluster får du felmeddelandet "Stämma av standardlastbalanseraren misslyckades" som visar värdet "SubCode" för SubscriptionRequestsThrottled och värdet "Status" på 429:
Det gick inte att stämma av standardlastbalanseraren.
Information: återförsöket av utboundReconciler misslyckades:
Kategori: ClientError;
Underkod: SubscriptionRequestsThrottled;
Beroende: Microsoft.Network/PublicIPAddresses;
OrginalError: autorest/azure: Tjänsten returnerade ett fel. Status=429
Code="SubscriptionRequestsThrottled"
Message="Number of requests for subscription '<subscription-id-guid>' and operation 'GET/SUBSCRIPTIONS/RESOURCEGROUPS/PROVIDERS/MICROSOFT. NETWORK/PUBLICIPADDRESSES har överskridit lagringsgränsen för serverdelen. Försök igen efter 6 sekunder.
AKSTeam: Nätverk, Retriable: false.
Begränsning av begäranden kan ske på olika Azure-komponenter, så felmeddelandet kan skilja sig beroende på vilken typ av resurs det här problemet uppstår på.
Orsak
Azure Resource Manager-begäranden begränsas. Information om hur Azure Resource Manager-gränser fungerar och de specifika gränserna per timme finns i Begränsa Resource Manager-begäranden.
Lösning 1: Använd en annan prenumeration
Om du har åtkomst till en annan prenumeration kan du helt enkelt distribuera klustret till den prenumerationen.
Lösning 2: Ändra dina åtkomstmönster
Lös problemet genom att undersöka dina åtkomstmönster för den begränsade prenumerationen. I följande tabell visas möjliga åtkomstmönster och motsvarande lösningar.
Åtkomstmönster | Lösning |
---|---|
Automatiserade skript söker ständigt igenom prenumerationen | Kör skripten mindre ofta |
Många användare har åtkomst till prenumerationen | Låt varje användare använda sin egen prenumeration |
Skript genomsöker varje lagringskonto i prenumerationen | Omfång för skriptet så att det bara frågar efter de resurser som det måste ha |
Mer information
Kontakta oss för att få hjälp
Om du har frågor eller behöver hjälp skapar du en supportförfrågan eller frågar Azure community support. Du kan också skicka produktfeedback till Azure-feedbackcommunityn.