Dela via


Felsöka felkoden "PublicIPCountLimitReached"

Den här artikeln beskriver hur du identifierar och löser felet "PublicIPCountLimitReached". Det här felet uppstår när du försöker skapa, uppdatera eller uppgradera ett AKS-kluster (Azure Kubernetes Service). Det här felet kan också orsakas av andra åtgärder som utlöser skapandet av en offentlig IP-adress, till exempel distribution av en offentlig lastbalanserare av Kubernetes Service-typ.

Symptom

Ett AKS-kluster som skapar, uppdaterar, uppgraderar eller andra åtgärder som utlöser skapandet av en offentlig IP-adress, till exempel distribution av en Kubernetes-tjänst som har en offentlig lastbalanserare, misslyckas och returnerar felmeddelandet "PublicIPCountLimitReached".

Orsak

Det här felet uppstår om du har nått det maximala antalet offentliga IP-adresser som tillåts för din prenumeration. Gränsen varierar beroende på din prenumerationstyp. Mer information om gränser för offentliga IP-adresser finns i den här detaljerade guiden.

Lösning

Följ dessa steg för att öka den offentliga IP-gränsen eller kvoten för din prenumeration:

  1. Gå till Azure Portal och välj de prenumerationer som du utför åtgärden för.

  2. I avsnittet Inställningar väljer du Användning + kvoter. Ange Providern till Nätverk och filtrera eventuellt efter regionen i aks-klustret.

  3. Leta upp posten Offentliga IP-adresser . På samma rad väljer du knappen Skapa en ny supportbegäran .

    Skärmbild som visar hur du skapar en supportbegäran om kvotökning.

  4. På sidan Ny supportbegäran anger du den nya gräns som du behöver och följer sedan anvisningarna för att skapa supportbegäran.

    Skärmbild som anger den nya gränsen för offentliga IP-adresser.

När kvotändringen börjar gälla försöker du igen med åtgärden som ursprungligen utlöste felet "PublicIPCountLimitReached".

Kontakta oss för att få hjälp

Om du har frågor eller behöver hjälp skapar du en supportförfrågan eller frågar Azure community support. Du kan också skicka produktfeedback till Azure-feedbackcommunityn.