Felsöka felkoden "Quotaexceeded"
I den här artikeln beskrivs hur du identifierar och löser felet "QuotaExceeded" som inträffar när du försöker uppgradera ett AKS-kluster (Azure Kubernetes Service).
Här är ett exempel på felmeddelandet:
Åtgärden resulterar i att kärnans kvotgränser överskrids Högsta tillåtna: X, Aktuell används: X, Ytterligare begärd: X
Förutsättningar
Den här artikeln kräver Azure CLI version 2.0.65 eller en senare version. Om du vill hitta versionsnumret kör du az --version
. Om du måste installera eller uppgradera Azure CLI kan du läsa Installera Azure CLI.
Mer detaljerad information om uppgraderingsprocessen finns i avsnittet "Uppgradera ett AKS-kluster" i Uppgradera ett AKS-kluster (Azure Kubernetes Service).
Symptom
En AKS-klusteruppgradering misslyckas och du får felmeddelandet "QuotaExceeded".
Orsak
Problemet uppstår om kvoten har nåtts. Din prenumeration har inte tillgängliga resurser som krävs för uppgradering.
Lösning
Om du vill höja gränsen eller kvoten för din prenumeration går du till supportbegäran Azure Portal och anger en supportbegäran för tjänst- och prenumerationsgränser (kvoter). I det här fallet måste du skicka ett supportärende för att öka kvoten för beräkningskärnor.
Kontakta oss för att få hjälp
Om du har frågor eller behöver hjälp skapar du en supportförfrågan eller frågar Azure community support. Du kan också skicka produktfeedback till Azure-feedbackcommunityn.