Dela via


Felet AADSTS70001 – Det gick inte att hitta programmet med identifieraren i katalogen

I den här artikeln beskrivs ett problem där du får felmeddelandet "Fel AADSTS70001 – Programmet med identifieraren hittades inte i katalogen." när du försöker logga in på en SAML-baserad enkel inloggning (SSO) konfigurerad app som har integrerats med Microsoft Entra-ID.

Symptom

Du får ett felmeddelande AADSTS70001 när du försöker logga in på ett program som har konfigurerats för att använda Microsoft Entra-ID för identitetshantering med hjälp av SAML-baserad enkel inloggning.

Orsak

Attributet Issuer som skickas från programmet till Microsoft Entra-ID i SAML-begäran matchar inte det identifierarvärde som har konfigurerats för programmet i Microsoft Entra-ID.

Åtgärd

Kontrollera att attributet i SAML-begäran matchar det identifierarvärde som Issuer konfigurerats i Microsoft Entra-ID.

På konfigurationssidan för SAML-baserad enkel inloggning i avsnittet Grundläggande SAML-konfiguration kontrollerar du att värdet i textrutan Identifierare matchar det identifierarvärde som anges i felet. Om det finns ett avslutande snedstreck i slutet av URL:en bör det också inkluderas.

Använda funktionen Testa enkel inloggning i administrationscentret för Microsoft Entra

Administrationscentret för Microsoft Entra kan hjälpa dig att felsöka SAML-konfigurationsfel.

Skärmbild av funktionen Testa enkel inloggning i administrationscentret för Microsoft Entra.

  1. I administrationscentret för Microsoft Entra går du till Företagsprogram och klickar på det program som behöver felsökning.
  2. Navigera till sidan Enkel inloggning med hjälp av den vänstra navigeringsmenyn
  3. Klicka på Testa det här programmet för att använda funktionen Testa enkel inloggning.
  4. Kopiera och klistra in felet som togs emot i avsnittet Lösa fel och klicka på Hämta lösningsvägledning
  5. Visa skillnaden mellan utfärdaren och identifieraren som hittades.
  6. Korrigera antingen utfärdaren eller identifieraren.

Mer information

En fullständig lista över felkoder för Active Directory-autentisering och auktorisering finns i Felkoder för Microsoft Entra-autentisering och auktorisering

Kontakta oss för att få hjälp

Om du har frågor eller behöver hjälp skapar du en supportförfrågan eller frågar Azure community support. Du kan också skicka produktfeedback till Azure-feedbackcommunityn.