Fel när Outlook för iOS eller Android ansluter till Exchange Server: Osäker anslutning eller Säker anslutning är inte tillgänglig
Ursprungligt KB-nummer: 4056392
Symptom
När du använder Microsoft Outlook för iOS eller Outlook för Android för att logga in på en instans av Exchange Server som använder ett SSL-certifikat för säkra anslutningar får du något av följande felmeddelanden:
Osäker anslutning. Vill du logga in ändå?
Säker anslutning är inte tillgänglig. Vill du logga in ändå?
Orsak
Det här problemet beror på att SSL-certifikatet inte stöds av någon av följande orsaker:
- SSL-certifikatet är ogiltigt eller har upphört att gälla.
- SSL-certifikatet är inte betrott.
Obs!
Outlook för iOS och Outlook för Android använder vanliga betrodda Java-certifikatutfärdare (CA). Om organisationens certifikat inte är signerat av en certifikatutfärdare som är en del av vanliga betrodda Java-certifikatutfärdare uppstår det här felet.
Åtgärd
Du kan ignorera det här felmeddelandet och logga in på Exchange Server. Det här felmeddelandet ska bara visas en gång.
Vi rekommenderar att du använder ett SSL-certifikat som stöds officiellt av Java CA-certifikatarkivet.
Så här verifierar du att ett certifikat är betrott av Java-certifikatutfärdarna
Hämta certifikatets certifikatutfärdare.
Ladda ned det senaste Java SE Development Kit (JDK). Det här paketet innehåller java-betrodda certifikatutfärdare.
Öppna ett kommandotolksfönster på en Windows-baserad dator eller öppna ett terminalfönster på en macOS-baserad dator.
Använd keytool-verktyget för att visa en lista över betrodda certifikatutfärdare genom att köra följande kommando:
keytool -keystore "<keystore location>" -storepass changeit -list -v
Obs!
På en macOS-baserad dator <kan nyckellagringsplatsparametern> vara "$JAVA_HOME/jre/lib/security/cacerts".
Kontrollera att certifikatutfärdare finns i listan.
Mer information om keytool-verktyget finns i följande artiklar: