Felsöka åtkomst till Azure-resurser som nekas i Privileged Identity Management
Om du har problem med Privileged Identity Management (PIM) i Microsoft Entra-ID kan informationen i den här artikeln hjälpa dig att lösa dessa problem.
Åtkomst till Azure-resurser nekas
Problem
Som aktiv ägare eller administratör för användaråtkomst för en Azure-resurs kan du se resursen i Privileged Identity Management men kan inte utföra några åtgärder som att göra en berättigad tilldelning eller visa en lista över rolltilldelningar från resursöversiktssidan. Dessa åtgärder resulterar i ett auktoriseringsfel.
Orsak
Det här problemet kan inträffa när rollen Administratör för användaråtkomst för PIM-tjänstens huvudnamn av misstag har tagits bort från prenumerationen. För att tjänsten Privileged Identity Management ska få åtkomst till Azure-resurser bör MS-PIM-tjänstens huvudnamn alltid ha rollen Administratör för användaråtkomst tilldelad.
Åtgärd
Tilldela rollen Administratör för användaråtkomst till tjänstens huvudnamn för privilegierad identitetshantering (MS–PIM) på prenumerationsnivå. Tilldelningen bör ge Privileged Identity Management-tjänsten åtkomst till Azure-resurserna. Rollen kan tilldelas på hanteringsgruppsnivå eller prenumerationsnivå, beroende på dina behov. Mer information om tjänstens huvudnamn finns i Tilldela ett program till en roll.