Dela via


XPS ファイル内が検索できず、XPS ファイルに関する重大イベントがイベント ログに出力される件について

こんにちは。Exchange サポートの粂田です。
今回は、XPS の拡張子を持つドキュメント ファイル (以降、XPS ファイルとします) が添付されたメールアイテムを、オンプレミスの Exchange Serverで送受信した際に発生する事象についてご紹介いたします。

現象

オンプレミスの Exchange Server のメールボックス内 ( "受信トレイ" 、"送信済みアイテム" の他に、"下書き" や "削除済みアイテム" 等も含みます) に、XPS ファイルが添付されたメールアイテムが存在する場合に、Outlook や Ootw などのメール クライアントから XPS ファイル内の文字列を検索しても該当のメール アイテムがヒットしないという現象が発生します。
また、以下のようなエラー イベントがイベント ログに記録されます。

======================================================================
ログの名前 : Microsoft-Office Server-Search/Operational
ソース : Microsoft-Office Server-Search
日付 : 2018/10/05 8:20:48
イベント ID : 64
タスクのカテゴリ: Document Parsing
レベル : 重大
コンピューター : E2013.contoso.com
説明:
Search Component: ContentEngineNode1-Fsis - Failed to load the format handler used to parse documents of the xps format. Error parsing document exchange://localhost/Attachment/3e908c15-90d1-4e8c-8ecd-5e25a2a97259/00822440-3336-4bd7-87dc-2fc2bb103738/e9302730-583d-45d9-bd1c-e300adf22fbb/98222f89-aa96-47ea-aaae-17a1189685c0/468151437433.0/aaaa.xps. Filter loading error. No filter installed for extension '.xps'.
======================================================================

発生環境

この現象は以下の条件に当てはまる環境を利用している場合に発生します。
・メールボックス サーバーとして Exchange Server 2013、もしくは Exchange Server 2016 を利用している。
・上記のメールボックス サーバーに後述の "XPS ビューアー" を導入していない。

原因

この現象が発生する原因は、XPS ファイルに対応する OS コンポーネントが足りていないこととなります。

メール アイテムがメールボックスに格納される際には通常、Exchange Search によるインデックス処理がメールボックス サーバー上で行われます。
インデックス処理は添付ファイルに対しても行われ、Exchange Server にインストールされている検索フィルターの有効/無効の設定と、iFilter と呼ばれる OS コンポーネントに従ってインデックス処理を行う添付ファイルを決定します。
以下の弊社公開情報にも記載されている通り、XPS ファイルの検索フィルターは既定で有効となっていますが、XPS ファイルの iFilter は既定では OS にインストールされていません。
これが本現象の発生する根本原因となります。

Title : Exchange Search によってインデックス処理されるファイル形式
URL : https://technet.microsoft.com/ja-jp/library/ee633485(v=exchg.150).aspx

影響

[現象] の章にも記載しましたが、XPS ファイルに含まれるテキストを利用した検索がうまくいかないという事象が発生します。

ただし、レベルが “重大” のイベントとして記録されるものの、Exchangeのその他の動作 (クライアントからのアクセスやメールの送受信等)に影響を与えるイベントではありません。また、XPS ファイルの添付されたメール アイテム自体の検索はメール アイテムの件名や本文中の文字列等を検索することで正常に行えることが期待できますので、「XPS ファイルが添付メール アイテムすべてが検索できなくなる」といったユーザー影響が発生するわけではない点にご注意下さい。

対処方法

"XPS ビューアー" の機能を各メールボックス サーバー上で有効化することで、 XPS ファイルの iFilter が OS にインストールされ、本現象は改善されます。
お客様のご利用環境下でも同様の事象が見られた場合には、Exchange がインストールされたマシンの OS 上で以下の手順を実行し、XPS ビューワーをインストールすることで事象が回避されるかどうかを確認して下さい。

<機能有効化手順>

  1. サーバー マネージャーを起動します。
  2. 右上の "管理" から [役割と機能の追加] を選択します。
  3. "開始する前に" 画面で [次へ] を選択します。
  4. "インストールの種類の選択" 画面で [役割ベースまたは機能ベースのインストール] をチェックして、[次へ] を選択します。
  5. "対象サーバーの選択" にて追加する対象のメールボックス サーバーを選択して、[次へ] を選択します。
  6. ウインドウ左側の "機能" を選択して "機能の選択画面" にて [XPS ビューアー] をチェックして、[次へ] を選択します。
  7. "インストール オプションの確認" にて、[インストール] を選択します。
  8. インストールが開始されます。インストール終了後のシステムの再起動は不要です。
  9. インストール完了後に以下のサービスを再起動してください。
    Microsoft Exchange Search Host Controller
    Microsoft Exchange Search

補足

Exchange Server にインストールされている検索フィルターが有効となっているかどうかは、Get-SearchDocumentFormat コマンドレットを Exhcnage 管理シェル上で実行することで確認することが可能です。こちらのコマンドレットの詳細につきましては、以下の弊社公開情報をご参照ください。

Title : Get-SearchDocumentFormat
URL : /en-us/powershell/module/exchange/mailbox-databases-and-servers/get-searchdocumentformat?view=exchange-ps

お手数をおかけいたしますが、XPS ファイル内の検索をメールクライアント上で検索する必要がある場合や、上記のイベントの出力を抑制されたい場合は、上記の対処を検討いただけますと幸いです。

今後とも、弊社サポート ブログならびにサポートチームをよろしくお願いいたします。
※本情報の内容(添付文書、リンク先などを含む)は、作成日時点でのものであり、予告なく変更される場合があります。