Поделиться через


Клиентский компьютер может украсть GUID Configuration Manager объекта неизвестного компьютера во время создания образа.

В этой статье содержатся сведения об устранении проблемы, с помощью которой создается уникальный идентификатор Configuration Manager (GUID) объекта неизвестного компьютера.

Исходная версия продукта: Configuration Manager (current branch)
Исходный номер базы знаний: 4471061

Симптомы

Configuration Manager current branch версии 1702 включает новую функцию, которая позволяет использовать предыдущую кнопку, чтобы повторить сбой последовательности задач в мастере последовательности задач при запуске в среде предустановки Microsoft Windows (Windows PE).

Дополнительные сведения об этой функции см . на предыдущей странице при сбое последовательности задач.

Эта функция представила следующую проблему:

Когда выбрана кнопка "Предыдущая", клиентский компьютер, на который изображено, может украсть уникальный идентификатор Configuration Manager (GUID) используемого объекта неизвестного компьютера (либо x64 Неизвестный компьютер, либо неизвестный компьютер x86).

Эта проблема устранена в накопительном пакете обновления для Configuration Manager current branch версии 1702.

Эта проблема также устранена во всех последующих версиях Текущей ветви Configuration Manager.

Однако начиная с Configuration Manager current branch версии 1702 неизвестные компьютеры, запущенные из среды выполнения мультимедиа или предварительной версии (PXE), могут не находить последовательности задач, предназначенные для них. В этом сценарии в SMSTS.log регистрируется следующее сообщение об ошибке:

Для этого компьютера нет доступных последовательностей задач. Убедитесь, что на этом компьютере объявлена по крайней мере одна последовательность задач.

Неопределенная ошибка (ошибка: 80004005; Источник: Windows)

Эта проблема может возникнуть, если на неизвестном компьютере выбрана кнопка "Назад " на странице выбора последовательности задач для запуска .

Эта проблема также устранена во всех последующих версиях Текущей ветви Configuration Manager.

Несмотря на применение накопительного пакета обновления в Configuration Manager current Branch версии 1702 или обновление до более поздней версии Configuration Manager, проблема по-прежнему возникает.

Причина

Эта проблема может продолжаться, так как исправление в накопительном пакете обновления для Configuration Manager current branch версии 1702 и более поздних версий Configuration Manager не позволяет устранить проблему только вперед. Это не устраняет проблему, если проблема в настоящее время существует в среде.

Поэтому проблема может продолжать возникать в Configuration Manager current branch версии 1702 или более поздней, даже после применения накопительного пакета обновления 1702 или более поздней версии. Это верно, если только не предпринята следующая процедура:

  • Обновите образы загрузки в точках распространения.
  • Повторно создайте загрузочный носитель с помощью обновленных образов.
  • Правильно очистите клиентский компьютер, который украл GUID.

Решение

Предупреждение

Не пытайтесь устранить эту проблему путем повторного создания объектов неизвестного компьютера. Это не правильно исправляет проблему, и она не препятствует повторному возникновению проблемы. Кроме того, существуют известные проблемы, возникающие в средах с несколькими объектами неизвестного компьютера для одного сайта. Если вы ранее попытались устранить эту проблему, повторно создав объекты неизвестного компьютера, см. статью "Удалить повторяющиеся объекты неизвестного компьютера".

Чтобы устранить эту проблему и запретить ее возврату в среде, выполните следующие действия.

  1. Обновите все образы загрузки в среде. Для этого щелкните правой кнопкой мыши изображения в консоли Configuration Manager и выберите пункт "Обновить точки распространения". Это помещает обновленные двоичные файлы Configuration Manager, содержащие исправление в загрузочный образ. Дополнительные сведения см. в разделе "Обновление точек распространения" с помощью образа загрузки.

  2. Если вы используете носитель в среде, создайте все носители в среде после обновления всех загрузочных образов в точках распространения. Это гарантирует, что обновленные образы загрузки, имеющие исправление, находятся в носителе, который используется в среде.

    Чтобы предотвратить использование старых образов загрузки, сертификаты для этих загрузочных образов можно заблокировать в консоли Configuration Manager в узле сертификатов безопасности>администрирования.> Чтобы убедиться, что проблема не повторяется, рекомендуется блокировать все сертификаты для всех носителей, созданных до обновления образов загрузки на шаге 1. Дата создания носителя отображается в столбце "Дата начала".

    Дополнительные сведения о создании носителя см. в разделе "Создание носителя последовательности задач".

  3. Клиентский компьютер, который украл GUID, должен быть правильно очищен.

Чтобы правильно очистить клиент, который украл GUID, выполните следующие действия.

  1. Определите компьютер, который приобрел GUID. Для этого проверьте свойства объекта Неизвестного компьютера (обычно x64 Неизвестный компьютер), запишите значение уникального идентификатора Configuration Manager, а затем запустите запрос в консоли Configuration Manager, чтобы определить объект компьютера с тем же ИДЕНТИФИКАТОРом GUID. Все эти действия можно выполнить из консоли. Для этого не нужно переходить в базу данных SQL Server.

  2. После идентификации компьютера, который приобрел украденный GUID, удаленно подключитесь к нему, а затем полностью очистите клиент Configuration Manager. Это включает в себя больше, чем просто удаление клиента. Вместо этого необходимо выполнить шаги 3-7.

  3. На клиентском компьютере C:\Windows\CCMSetupCCMSetup.exe /uninstall выполните команду в командной строке с повышенными привилегиями.

  4. Мониторинг диспетчера задач до тех пор, пока CCMSetup не завершит работу. Дважды проверьте файл ccmsetup.log, чтобы убедиться, что клиент был удален правильно.

  5. На клиентском компьютере удалите следующие каталоги:

    • C:\Windows\CCM
    • C:\Windows\CCMSetup

    Примечание.

    Чтобы полностью удалить эти каталоги, может потребоваться перезагрузить компьютер.

  6. На клиентском компьютере удалите следующие разделы реестра (если они существуют):

    • HKEY_LOCAL_MACHINE\Software\Microsoft\CCM
    • HKEY_LOCAL_MACHINE\Software\Microsoft\CCMSetup
    • HKEY_LOCAL_MACHINE\Software\Microsoft\SMS
  7. На клиентском компьютере удалите файл C:\Windows\SMSCFG.ini.

  8. На клиентском компьютере удалите все сертификаты в узле SMS>Certificates в консоли сертификатов для учетной записи компьютера. Для этого выполните следующие шаги.

    1. Запустите MMC.exe в командной строке с повышенными привилегиями.

    2. В меню Файл выберите Добавить или удалить оснастку.

    3. Выберите сертификаты и нажмите кнопку "Добавить".

    4. Выберите учетную запись компьютера и нажмите кнопку "Далее".

    5. Выберите локальный компьютер и нажмите кнопку "Готово".

    6. Нажмите кнопку ОК.

    7. Перейдите к сертификатам>SMS-сертификатов.>

    8. В области результатов щелкните правой кнопкой мыши каждый сертификат, указанный в узле сертификатов SMS>certificates>, и выберите "Удалить". Повторите этот шаг, пока не будут удалены все сертификаты.

    9. Закройте консоль сертификатов.

  9. Удалите запись обижающего компьютера из консоли Configuration Manager. Опять же, для этого не нужно переходить в базу данных SQL Server. Запись можно удалить из консоли Configuration Manager. Убедитесь, что после выполнения действий 1-8 выполните указанные ниже действия. Это может привести к повторному воссоздаю записи, если отчеты клиента создаются резервной копии до полной очистки.

  10. Переустановите клиент Configuration Manager на неоправданном клиентском компьютере.

Удаление повторяющихся объектов неизвестного компьютера

Если объекты неизвестного компьютера были воссозданы на сайте при попытке устранить проблему, следует удалить дополнительные объекты неизвестного компьютера. Для этого необходимо удалить все текущие объекты неизвестного компьютера для затронутого сайта, а затем создать новый набор объектов неизвестного компьютера для сайта. Удаление объектов неизвестного компьютера можно выполнить только из базы данных SQL Server. Его нельзя сделать из консоли Configuration Manager.

Примечание.

При наличии нескольких первичных сайтов можно использовать несколько объектов неизвестного компьютера. Однако каждый сайт должен иметь только один объект Неизвестного компьютера на архитектуру. Например, должен быть только один объект x64 с меткой x64 Unknown Computer и только один объект x86, помеченный x86 Unknown Computer.

Чтобы удалить дополнительные объекты неизвестного компьютера, выполните следующие действия.

  1. Убедитесь, что у вас есть текущая и допустимая резервная копия сайта Configuration Manager с помощью встроенной задачи обслуживания резервного копирования.

  2. Откройте консоль Configuration Manager. Если существует несколько первичных сайтов, рекомендуется открыть консоль Configuration Manager, подключенную к сайту центра администрирования.

  3. В консоли Configuration Manager перейдите к коллекциям устройств "Активы и соответствие требованиям>>".

  4. Дважды щелкните коллекцию "Все неизвестные компьютеры ".

  5. В области результатов сортируйте объекты в коллекции "Все неизвестные компьютеры" , выбрав столбец "Код сайта".

  6. Обратите внимание, существует ли несколько объектов x64 Unknown Computer или x86 Unknown Computer для любого отдельного сайта.

  7. Если для любого отдельного сайта есть несколько объектов x64 Unknown Computer или x86 Unknown Computer, щелкните правой кнопкой мыши столбцы в области результатов и добавьте идентификатор ресурса в список столбцов.

  8. Определите значение идентификатора ресурса для каждого объекта неизвестного компьютера x64 и каждого объекта неизвестного компьютера x86 для любого сайта. Обязательно запишите идентификатор ресурса для всех объектов неизвестного компьютера, даже если дублируется только один из объектов неизвестного компьютера.

  9. После определения идентификаторов ресурсов объектов неизвестных компьютеров для сайта можно удалить объекты x64 Unknown Computer и объекты x86 Unknown Computer для сайта.

  10. Откройте СРЕДУ SQL Server Management Studio и подключитесь к базе данных для сайта, на котором размещены дополнительные объекты неизвестного компьютера.

  11. Разверните узел "Базы данных" и выберите базу данных Configuration Manager (обычно CM_Site_Code).

  12. На панели инструментов нажмите Создать запрос.

  13. Убедитесь, что выбрана правильная база данных в раскрывающемся меню слева от кнопки "Выполнить " на панели инструментов.

  14. В области запросов выполните следующий SQL-запрос:

    SELECT C.CollectionID, C.SiteID, C.CollectionName, CM.MachineID, CM.Name FROM Collections C JOIN CollectionMembers CM ON C.SiteID = CM.SiteID JOIN UnknownSystem_DISC USD ON USD.ItemKey = CM.MachineID
    

    Этот запрос отображает все коллекции, к которым принадлежат все объекты неизвестного компьютера. Используйте этот запрос, чтобы определить, какие коллекции являются элементами объектов неизвестного компьютера. Запишите эти сведения, чтобы при создании нового набора объектов неизвестного компьютера они могли быть добавлены обратно в соответствующие коллекции. Идентификатор ресурса указан в столбце MachineID.

  15. В области запросов выполните следующий SQL-запрос:

    SELECT * FROM UnknownSystem_DISC WHERE ItemKey IN ('Resource_ID_1','Resource_ID_2', 'Resource_ID_3')
    

    В этом запросе Resource_ID_x используется идентификатор ресурса каждого объекта неизвестного компьютера для сайта, как определено на шаге 9. Например, если идентификаторы ресурсов 2046820354 и 2046820355, запрос будет следующим образом:

    SELECT * FROM UnknownSystem_DISC WHERE ItemKey IN ('2046820354','2046820355')
    
  16. Убедитесь, что записи, возвращаемые запросом на шаге 15, верны. Если они есть, выполните следующий запрос, чтобы удалить записи:

    DELETE FROM UnknownSystem_DISC WHERE ItemKey IN ('Resource_ID_1','Resource_ID_2', 'Resource_ID_3')
    

    В этом запросе Resource_ID_x используется идентификатор ресурса каждого объекта неизвестного компьютера для сайта, как определено на шаге 9. Например, если идентификаторы ресурсов 2046820354 и 2046820355, запрос удаления будет следующим образом:

    DELETE FROM UnknownSystem_DISC WHERE ItemKey IN ('2046820354', '2046820355')
    

    Примечание.

    Не забудьте удалить все объекты неизвестного компьютера для затронутого сайта, как x64, так и x86, даже если только один из них был дублирован.

  17. Следуйте разделу Повторное создание объектов неизвестного компьютера в случае случайного удаления , чтобы создать новые объекты неизвестного компьютера для затронутого сайта.

  18. Вернитесь в консоль Configuration Manager, а затем перейдите к коллекциям устройств "Активы и соответствие требованиям>>".

  19. Щелкните правой кнопкой мыши коллекцию "Все неизвестные компьютеры" и выберите "Обновить членство".

  20. Подождите несколько минут, а затем нажмите кнопку "Обновить". Убедитесь, что для каждого сайта существует только один объект неизвестного компьютера x64 или объект неизвестного компьютера x86. Если объекты не отображаются, подождите несколько минут и повторите попытку.

  21. После появления новых объектов неизвестного компьютера добавьте их обратно в соответствующие коллекции, как определено на шаге 14.

  22. Повторите шаги 10-21 для всех дополнительных первичных сайтов по мере необходимости.

Повторное создание объектов неизвестного компьютера в случае случайного удаления

Если по какой-либо причине все объекты неизвестных компьютеров случайно удаляются для любого сайта, использующего этот процесс, их можно повторно создать, выполнив следующие действия. Эти действия необходимо выполнить только в том случае, если для сайта отсутствуют объекты неизвестного компьютера. Если на сайте существует только один из двух объектов неизвестных компьютеров, удалите один оставшийся объект неизвестного компьютера, выполнив действия, описанные в разделе "Удаление повторяющихся неизвестных компьютеров " этой статьи, а затем выполните следующие действия.

  1. Войдите на сервер первичного сайта, в который отсутствуют объекты неизвестного компьютера.

  2. Из командной строки с повышенными привилегиями запустите следующую команду:

    REG.exe ADD "HKLM\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_DISCOVERY_DATA_MANAGER" /v CreatedUnknownDDR /t REG_DWORD /d 0 /f
    

После обновления этого значения раздела реестра объекты неизвестного компьютера должны быть автоматически повторно созданы в ближайшее время. Вы можете проверить ход создания объектов неизвестного компьютера в файле DDM.log на сервере первичного сайта.

Чтобы ускорить восстановление записей неизвестного компьютера, перезапустите SMS_DISCOVERY_DATA_MANAGER поток, выполнив следующие действия:

  1. Откройте консоль Configuration Manager на основном сайте, из которого отсутствуют объекты неизвестного компьютера, а затем перейдите к состоянию компонента состояния> системы мониторинга.>>

  2. На панели инструментов выберите "Пуск>Configuration Manager Service Manager".

  3. В Configuration Manager Service Manager разверните узел в коде сайта и выберите компоненты.

  4. В области результатов щелкните правой кнопкой мыши SMS_DISCOVERY_DATA_MANAGER и выберите "Запрос". Поток должен отображаться как запущенный.

  5. Щелкните правой кнопкой мыши SMS_DISCOVERY_DATA_MANAGER и нажмите кнопку " Остановить".

  6. Щелкните правой кнопкой мыши SMS_DISCOVERY_DATA_MANAGER и нажмите кнопку "Запрос".

    Примечание.

    Поток должен отображаться как остановленный.

  7. Щелкните правой кнопкой мыши SMS_DISCOVERY_DATA_MANAGER и нажмите кнопку "Пуск".

  8. Щелкните правой кнопкой мыши SMS_DISCOVERY_DATA_MANAGER и нажмите кнопку "Запрос".

    Примечание.

    Поток должен отображаться как запущенный.

  9. Закройте окно Configuration Manager Service Manager.

Объекты неизвестного компьютера должны быть автоматически повторно созданы в ближайшее время. Ход выполнения этого процесса можно проверить в файле DDM.log на сервере первичного сайта.