Синхронизация каталогов с идентификатором Microsoft Entra останавливается или вы предупреждаете, что синхронизация не зарегистрирована более чем за день.
В этой статье описывается проблема с производительностью в средстве синхронизации Azure Active Directory. Средство либо останавливает синхронизацию, либо сообщает, что синхронизация не выполняется более 24 часов.
Исходная версия продукта: Идентификатор Microsoft Entra, Microsoft Intune, Azure Backup, Управление удостоверениями Office 365
Исходный номер базы знаний: 2882421
Примечание.
Статья была полезной? Ваши входные данные важны для нас. Нажмите кнопку "Отзывы" на этой странице, чтобы сообщить нам, насколько хорошо эта статья работала для вас или как мы можем улучшить ее.
Симптомы
Вы испытываете один из следующих симптомов:
- Средство синхронизации Microsoft Azure Active Directory останавливает синхронизацию.
- Вы получаете сообщения электронной почты, которые говорят, что идентификатор Microsoft Entra не зарегистрировал попытку синхронизации за последние 24 часа.
- В средстве
MIISClient.exe
вы получите сообщение "Остановленный сервер-вниз" или сообщение "Остановленное-расширение-DLL-Исключение". - Не удается запустить одну или несколько служб синхронизации каталогов.
Примечание.
По умолчанию синхронизация каталогов выполняется каждые три часа.
Причина
Причина этого может заключаться в следующем:
Одна из указанных ниже проблем с рабочей или учебной учетной записью, которая использовалась в мастере настройки синхронизации каталогов:
- Учетная запись удалена.
- Учетная запись отключена.
- Срок действия пароля учетной записи истек.
Одна из указанных ниже проблем с учетной записью, которая используется для входа в одну или несколько служб синхронизации каталогов:
- Учетная запись удалена.
- Учетная запись отключена.
- Срок действия пароля учетной записи истек.
Примечание.
Учетная запись входа для службы синхронизации каталогов настраивается автоматически и не должна быть изменена.
Учетная запись администратора, которая используется для синхронизации каталогов, изменена.
Наблюдаются проблемы с сетевым подключением.
Службы синхронизации каталогов остановлены.
Решение
Метод 1. Вручную убедитесь, что служба запущена и что учетная запись администратора может войти в систему.
Нажмите кнопку "Пуск", выберите "Запустить", введите Services.msc и нажмите кнопку "ОК".
Найдите службу устройства синхронизации Microsoft Entra, а затем проверьте, запущена ли служба. Если служба не запущена, щелкните ее правой кнопкой мыши и нажмите кнопку "Пуск".
- Если вы используете средство синхронизации Azure Active Directory, найдите службу синхронизации Azure Active Directory.
- Если вы используете Microsoft Entra Connect, найдите Службу синхронизации Microsoft Azure AD.
Убедитесь, что учетная запись администратора, используемая для синхронизации каталогов, по-прежнему существует. И убедитесь, что учетная запись разрешена для входа. Если учетная запись по-прежнему существует, сбросьте пароль и убедитесь, что вы можете войти. Если появится запрос, измените пароль.
Если вы не знаете учетную запись глобального администратора, которая используется для настройки синхронизации каталогов, выполните следующие действия на сервере, на котором установлен модуль синхронизации каталогов:
Перейдите к
%ProgramFiles%\Microsoft Azure AD Sync\UIShell\
и запустите Miisclient.exe.Примечание.
Если вы используете Microsoft Entra Connect или службу синхронизации Azure Active Directory, нажмите кнопку "Пуск", а затем найдите и откройте службу синхронизации.
Выберите Соединители и дважды щелкните соединитель Microsoft Entra.
Выберите Подключение.
Запишите значение UserName. Это учетная запись глобального администратора, используемая для настройки синхронизации каталогов.
На сервере синхронизации каталогов запустите мастер настройки устройства синхронизации Microsoft Entra. Введите новый пароль для учетной записи администратора, которая используется для синхронизации каталогов, а затем выполните оставшиеся шаги в мастере.
При появлении запроса установите флажок "Принудительной синхронизации каталогов ".
Метод 2. Устранение проблемы с учетной записью входа в систему для службы синхронизации каталогов
Нажмите кнопку "Пуск", выберите "Запустить", введите Services.msc и нажмите кнопку "ОК".
Найдите службу устройства синхронизации Microsoft Entra:
- Если вы используете средство синхронизации Azure Active Directory, найдите службу синхронизации Azure Active Directory.
- Если вы используете Microsoft Entra Connect, найдите Службу синхронизации Microsoft Azure AD. Щелкните правой кнопкой мыши службу и выберите пункт "Свойства". На вкладке "Вход в систему" запишите имя учетной записи, указанное в списке.
Примечание.
Перенастройка любой из служб синхронизации каталогов для входа в локальную системную учетную запись не поддерживается и может привести к проблемам.
На контроллере домена или на компьютере с установленными средствами администрирования откройте Пользователи и компьютеры Active Directory (Dsa.msc), щелкните правой кнопкой мыши доменное имя и нажмите кнопку "Найти". Введите имя учетной записи, которую вы указали на шаге 2, а затем нажмите кнопку "Найти сейчас".
- Если вы найдете учетную запись, перейдите к шагу 4.
- Если вы не можете найти учетную запись, возможно, она была удалена. Дополнительные сведения о восстановлении этой учетной записи см . в пошаговом руководстве по корзине Active Directory. Если не удается восстановить учетную запись, необходимо удалить и переустановить клиент синхронизации каталогов.
Щелкните правой кнопкой мыши учетную запись и выберите пункт "Свойства". На вкладке "Учетная запись" в разделе "Параметры учетной записи" выполните следующие действия.
- Убедитесь, что флажок "Пароль" никогда не истекает .
- Убедитесь, что флажок "Учетная запись отключена ". Затем выполните одно из следующих действий:
- Если установлен флажок "Учетная запись отключена", снимите ее, чтобы включить учетную запись. Затем перезапустите службу устройства синхронизации Microsoft Entra. Для этого нажмите кнопку "Пуск", выберите "Выполнить", введите Services.msc и нажмите кнопку "ОК". Найдите службу, щелкните ее правой кнопкой мыши и нажмите кнопку " Перезапустить".
- Если вы используете средство синхронизации Azure Active Directory, найдите службу синхронизации Azure Active Directory.
- Если вы используете Microsoft Entra Connect, найдите Службу синхронизации Microsoft Azure AD.
- Если флажок "Учетная запись отключена", перейдите к шагу 5.
Если флажок "Учетная запись отключена" уже снят, возможно, что пароль для учетной записи был изменен вручную. Чтобы задать новый пароль, откройте Пользователи и компьютеры Active Directory, найдите и щелкните правой кнопкой мыши учетную запись, а затем выберите "Сбросить пароль", чтобы сбросить пароль. Обратите внимание на пароль, который вы задали, так как его придется использовать на следующем шаге.
Задайте пароль для учетной записи входа в службы синхронизации каталогов:
Нажмите кнопку "Пуск", выберите "Запустить", введите Services.msc и нажмите кнопку "ОК".
Задайте пароль для следующих служб в зависимости от используемого клиента. Для этого щелкните правой кнопкой мыши соответствующую службу, выберите "Свойства", перейдите на вкладку "Вход " и введите пароль.
Клиент синхронизации Microsoft Entra Microsoft Entra Connect
Служба синхронизации Forefront Identity Manager
SQL Server (MOSONLINE) (при наличии)
Служба синхронизации Azure Active Directory
Синхронизация Azure ADЗапустите службу или службы, для которых вы задали новый пароль.
Свяжитесь с нами для получения помощи
Если у вас есть вопросы или вам нужна помощь, создайте запрос в службу поддержки или обратитесь за поддержкой сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.