Поделиться через


Сбой платежа карта из-за неподдерживаемого типа карта

Эта статья поможет устранить ошибку "Тип карта не является принятой формой оплаты", которая возникает при обработке кредитных или дебетовых карта транзакций в Microsoft Dynamics 365 Commerce.

Симптомы

Сбой платежа карта (или подарочного карта) со следующим сообщением об ошибке в точке продажи (POS):

Тип карта не является принятой формой оплаты. Используйте другой карта оплаты, а затем повторите попытку.

В журнале событий также отображается следующее сообщение об ошибке:

Тип карточки с идентификатором Unknown не найден.

Примечание.

Оплата карта успешно авторизована до получения сообщения об ошибке. После появления сообщения об ошибке платеж карта отменяется службой оплаты.

Причина

Типы карта, настроенные для способа оплаты канала, не соответствуют платежным данным, возвращенным соединителем оплаты.

Типы карт сопоставляются сочетанием диапазона ячейки, карта идентификатора типа (например, Кредит или Дебет) и типа записи (Swipe или Manual).

Решение 1

Чтобы устранить эту проблему, убедитесь, что типы карта настроены правильно для типа тендера и канала.

  • Проверьте журнал событий в POS или журнале клиента POS в Microsoft Dynamics Lifecycle Services (LCS) на наличие следующих имен событий, чтобы узнать, какие значения типов карта используются.

    • posPaymentCardTypeFilterByBinRangeIsDebitOrCredit

      Это событие указывает, получил ли обработчик платежей тип карта как Кредит, Дебетовый или Подарочный карта. Если значение не так, как ожидалось, источник финансирования может быть задан или отправлен неправильно.

    • posPaymentCardTypeFilterByBinRangeIsSwipe

      Это событие указывает, будет ли пользователь провести пальцем или вручную ввести карта через pos-терминал. Если тип карта с соответствующим диапазоном ячейки не разрешает ввод вручную, но карта был введен с помощью записи прокрутки, это может привести к отнюдь не сопоставлению типов карта.

    Примечание.

    POS ищет соответствующий диапазон корзины на основе типа карта, возвращенного обработчиком платежей или соединителем.

    • Если тип карта — "Кредитная карта", pos-терминал ищет все типы карта, заданные для магазина как "Международный кредитный карта", и ищет соответствие диапазона корзины в этих типах карта.
    • Если тип карта — "Дебетовая карта", pos-терминал ищет все типы карта, заданные для магазина как "Международный дебетовый карта", и соответствует этим диапазонам корзины.
    • Если соединитель оплаты не задает тип карта, pos-терминал по умолчанию считает его кредитным карта и ищет совпадение в типе "Международный кредитный карта".
  • В коммерческой штаб-квартире перейдите к разделу Розничная торговля и Канал>торговли Настройка>методов оплаты>Типы карт.

    • Проверьте, существует ли карта торговая марка. Добавьте карта торговую марку, если она отсутствует.
    • Проверьте, правильно ли присвоен тип карта (международный кредитный карта или Международный дебетовый карта) торговой марке.
    • Выберите Номера карточек на панели инструментов и убедитесь, что задан диапазон ячейки для покрытия неприемлемого номера карта.

    Примечание.

    Если кредитный или дебетовый карта настроен правильно, но вы по-прежнему получаете сообщение об ошибке, эта ошибка может быть вызвана тем, что соединитель оплаты возвращает неправильный идентификатор типа карта. Например, соединитель оплаты возвращает тип "Дебетовая карта", но в коммерческой штаб-квартире задан только тип "Кредит карта". В этом случае создайте тип карта с одинаковым диапазоном корзины для кредитных и дебетовых карт.

  • В коммерческой штаб-квартире перейдите к форме канала или магазина, в рамках которого возникла проблема.

    1. Выберите Настройка>методов оплаты и выберите метод оплаты, используемый картами.
    2. Выберите Настройка электронных платежей и добавьте в метод оплаты типы кредитных и дебетовых карта.

Если были внесены какие-либо изменения в типы карт или метод оплаты, запустите задание CDX 1090 и убедитесь, что его состояние отображается как примененное.

Решение 2

Чтобы устранить эту проблему, проверка идентификатор, заданный fundingSource в Adyen.

В Dynamics 365 Payment Connector for Adyen тип карта задается на основе идентификатора fundingSource в ответе авторизации Adyen. fundingSource Если идентификатор не задан Adyen в ответах авторизации, тип карта не будет задан в соединителе. Однако pos-терминал по умолчанию использует значение "кредит" при поиске диапазонов ячеек.

Если у вас возникла проблема с "отсутствующим диапазоном ячейки", но вы недавно не изменили параметры диапазона карта типа, проблема может быть вызвана одной из следующих причин:

  1. Недавнее обновление встроенного ПО Adyen начало отправку идентификатора fundingSource .
  2. Идентификатор fundingSource недавно был включен на портале Adyen.
  3. Диапазон ячейки не задан для этого конкретного типа карта или карта.

В встроенном ПО Adyen версии 1.42.4 и более ранних версиях fundingSource идентификатор не является обязательным, и Adyen не отправлял его. В встроенном ПО Adyen версии 1.44 и более поздних версиях источник финансирования будет отправлен обратно в ответе авторизации в качестве обязательного поля для терминала POS, а свойство не контролируется какой-либо конфигурацией на портале Adyen.

Чтобы включить или отключить источник финансирования на портале Adyen, выполните следующие действия.

  1. Войдите на портал Adyen.
  2. На верхней панели навигации выберитеURL-адреса API учетных записей>>Дополнительные параметры данных.
  3. Прокрутите вниз, чтобы найти параметр Источник финансирования , включить или отключить его, а затем сохранить изменения.

Дополнительная информация

Дополнительные сведения см. в разделе Настройка методов оплаты.

Заявление об отказе от ответственности за сведения о продуктах сторонних производителей

В этой статье упомянуты программные продукты независимых производителей. Корпорация Майкрософт не дает никаких гарантий, подразумеваемых и прочих, относительно производительности и надежности этих продуктов.