Поделиться через


Устранение неполадок в развертывании при перезагрузке или изменении размера существующей виртуальной машины Windows в Azure

Область применения: ✔️ Виртуальные машины Windows

Когда вы запускаете остановленную виртуальную машину Azure или изменяете размер существующей виртуальной машины Azure, часто возникает ошибка выделения ресурсов. Это происходит, когда кластер или регион не имеют доступных ресурсов или не поддерживают запрашиваемый размер виртуальной машины.

Если эта статья не помогла устранить вашу проблему с Azure, посетите форумы по Azure на сайтах MSDN и Stack Overflow. Описание своей проблемы можно опубликовать на этих форумах или написать в Twitter (@AzureSupport). Также можно отправить запрос в службу поддержки Azure. Чтобы отправить такой запрос, на странице поддержки Azure щелкните Получить поддержку.

Сбор журналов действий

Для устранения неполадок прежде всего соберите журналы действий, чтобы определить ошибку, связанную с этой проблемой. Ниже представлены ссылки на подробные сведения о процессе.

Просмотр операций развертывания

Просмотр журналов действий для управления ресурсами Azure

Проблема: ошибка во время запуска остановленной виртуальной машины

При попытке запустить остановленную виртуальную машину отображается сообщение об ошибке выделения.

Причина

Запрос на запуск остановленной виртуальной машины нужно выполнять в исходном кластере, в котором размещена облачная служба. Но этот кластер не имеет свободного места для выполнения запроса.

Решение

  • Остановите все виртуальные машины в группе доступности, затем перезапустите каждую из них.

    1. Для этого последовательно выберите Группы ресурсов>имя вашей группы ресурсов>Ресурсы>имя вашей группы доступности>Виртуальные машины>имя вашей виртуальной машины>Остановить.
    2. После остановки всех виртуальных машин выберите каждую из них и нажмите кнопку "Пуск".
  • Повторите запрос на перезапуск позже.

Проблема: ошибка при изменении размера существующей виртуальной машины

При попытке изменить размер существующей виртуальной машины отображается сообщение об ошибке выделения.

Причина

Запрос на изменение размера виртуальной машины нужно выполнять в исходном кластере, в котором размещена облачная служба. Но этот кластер не поддерживает запрашиваемый размер виртуальной машины.

Решение

  • Повторите запрос с указанием меньшего размера виртуальной машины.

  • Если нельзя изменить размер запрошенной виртуальной машины,

    1. остановите все виртуальные машины в группе доступности.

      • Для этого последовательно выберите Группы ресурсов>имя вашей группы ресурсов>Ресурсы>имя вашей группы доступности>Виртуальные машины>имя вашей виртуальной машины>Остановить.
    2. После остановки всех виртуальных машин увеличьте размер требуемой виртуальной машины.

    3. Выберите виртуальную машину с измененным размером, нажмите кнопку Запуститьи запустите каждую из остановленных виртуальных машин.

Ошибка при остановке, запуске, перезапуске или повторном развертывании существующей виртуальной машины

При попытке остановить, запустить, перезапустить или повторно развернуть существующую виртуальную машину процесс завершается ошибкой, и при обработке сетевого профиля виртуальной машины возникает непредвиденная ошибка. Повторите попытку позже" сообщение об ошибке. При возникновении этой ошибки виртуальная машина помещается в состояние сбоя.

Причина

Эта проблема возникает, если существует проблема при выделении или обновлении сетевых ресурсов.

Решение

Попробуйте повторно применить состояние виртуальной машины. Эта операция повторно запускает подготовку виртуальной машины и помогает устранить сбой состояния виртуальной машины, возникающий при сбое подготовки виртуальной машины в ходе выполнения предыдущего действия виртуальной машины.

  1. Перейдите к виртуальной машине, которая зависла в состоянии сбоя.
  2. В разделе Справка выберите Повторное развертывание и применение.
  3. Выберите вариант Применить повторно.

Следующие шаги

При возникновении проблем во время создания виртуальной машины Windows в Azure ознакомьтесь со статьей, посвященной устранению неполадок в развертывании.

Свяжитесь с нами для получения помощи

Если у вас есть вопросы или вам нужна помощь, создайте запрос в службу поддержки или обратитесь за поддержкой сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.