Поделиться через


Надстройка интеграции Team Foundation Server с Office не запускается

Эта статья поможет устранить ошибку, которая возникает, когда надстройка Team Foundation Server 2015 Office не работает.

Исходная версия продукта: Team Foundation Server
Исходный номер базы знаний: 3192409

Симптомы

Вы обнаружите, что надстройка Team Foundation Server 2015 Office не работает, так как она не подписана доверенным издателем. Эта проблема возникает при выполнении следующих условий:

  • Вы используете 32-разрядную версию Office на 64-разрядном компьютере.

  • У вас есть версия Team Foundation Server, которая раньше, чем Team Foundation Server 2015 с обновлением 3.

  • В параметрах Office флажок "Требуемые надстройки приложения", подписанные доверенным издателем, установлен в разделе "Файл ->>Параметры -Параметры "Центр управления безопасностью".>

Причина

Эта проблема возникает, если в поле "Расположение надстройки" есть кавычки. Это предотвращает проверку издателя в Office. Чтобы убедиться, что это причина проблемы, перейдите к файлу ->Параметры ->Надстройки, выберите надстройку Team Foundation, а затем просмотрите поле "Расположение ", чтобы узнать, находится ли путь к расположению внутри кавычки.

Снимок экрана: пример проверки поля расположения надстройки.

Решение

Исправление этой проблемы включается в Team Foundation Server 2015 с обновлением 3 и более поздними версиями Team Foundation Server. Рассмотрите возможность обновления до обновления 3, чтобы устранить эту проблему.

Если у вас есть более ранняя сборка, вы можете удалить кавычки из соответствующего раздела реестра. Перед изменением раздела реестра создайте копию резервной копии.

Для этого можно использовать файл скрипта .reg или вручную изменить строку в редакторе реестра. Чтобы вручную изменить строку, выполните следующие действия.

  1. Нажмите кнопку "Пуск", нажмите кнопку "Запустить", а затем введите regedit.

  2. Перейдите к следующему подразделу Team Foundation Server 2015:

    [HKEY_CLASSES_ROOT\WOW6432Node\CLSID\{04986E13-556D-463F-ADBD-9D8CAD03707B}\InprocServer32]

  3. Щелкните правой кнопкой мыши запись (по умолчанию), нажмите кнопку "Изменить", а затем удалите кавычки в начале и конце значения в столбце данных.

Дополнительная информация

Если после удаления кавычки по-прежнему возникают ошибки, убедитесь, что корпорация Майкрософт указана в качестве доверенного издателя на компьютере. Если это не так, необходимо установить сертификат Майкрософт.

Свяжитесь с нами для получения помощи

Если у вас есть вопросы или вам нужна помощь, создайте запрос в службу поддержки или обратитесь за поддержкой сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.