Устранение неполадок с кодом ошибки SubnetIsFull во время обновления кластера AKS
В этой статье описывается, как определить и устранить ошибку SubnetIsFull, возникающую при попытке обновить кластер Служба Azure Kubernetes (AKS).
Ниже приведен пример сообщения об ошибке:
Не удалось масштабировать имя пула <агентов узлов в службе Kubernetes "<NAME>".> Ошибка: повторная попытка VMSSAgentPoolReconciler: Code='SubnetIsFull' Message='<SUBNET NAME>\ с префиксом префикса <>адреса\ не имеет достаточной емкости для IP-адресов. Details=[]
Предварительные требования
Для этой статьи требуется Azure CLI версии 2.0.65 или более поздней версии. Чтобы найти номер версии, выполните команду az --version
. Если вам нужно установить или обновить Azure CLI, см. инструкции по установке Azure CLI.
Дополнительные сведения о процессе обновления см. в разделе "Обновление кластера AKS" в разделе об обновлении кластера Служба Azure Kubernetes (AKS).
Симптомы
Обновление кластера AKS завершается сбоем, и вы получите сообщение об ошибке SubnetIsFull.
Причина
Эта ошибка возникает, если в кластере недостаточно IP-адресов для создания нового узла.
При планировании операции обновления или масштабирования рассмотрите количество необходимых IP-адресов. Если диапазон IP-адресов, настроенный в кластере, поддерживает только фиксированное количество узлов, операция обновления или масштабирования завершится ошибкой. Дополнительные сведения см. в разделе "Планирование IP-адресов кластера" в разделе "Настройка сети Azure CNI в Служба Azure Kubernetes (AKS)".
Решение
Уменьшите узлы кластера, чтобы зарезервировать IP-адреса для обновления.
Если масштабирование не является вариантом, и CIDR виртуальной сети имеет достаточно IP-адресов, попробуйте добавить пул узлов с уникальной подсетью:
- Добавьте новый пул узлов пользователя в виртуальную сеть в более крупной подсети.
- Переключите исходный пул узлов на тип пула системных узлов.
- Увеличение масштаба пула узлов пользователя.
- Уменьшение масштаба исходного пула узлов.
Свяжитесь с нами для получения помощи
Если у вас есть вопросы или вам нужна помощь, создайте запрос в службу поддержки или обратитесь за поддержкой сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.