Поделиться через


Устранение неполадок с кодом ошибки PublicIPCountLimitReached

В этой статье объясняется, как определить и устранить ошибку PublicIPCountLimitReached. Эта ошибка возникает при попытке создать, обновить или обновить кластер Служба Azure Kubernetes (AKS). Эта ошибка также может быть вызвана любым другим действием, которое активирует создание общедоступного IP-адреса, например развертывание общедоступного балансировщика нагрузки типа службы Kubernetes.

Симптомы

Создание, обновление, обновление кластера AKS или другая операция, которая активирует создание общедоступного IP-адреса, например развертывание службы Kubernetes с общедоступным балансировщиком нагрузки, завершается сбоем и возвращает сообщение об ошибке PublicIPCountLimitReached.

Причина

Эта ошибка возникает, если вы достигли максимального количества общедоступных IP-адресов, разрешенных для вашей подписки. Ограничение зависит от типа подписки. Дополнительные сведения об ограничениях общедоступных IP-адресов см. в этом подробном руководстве.

Решение

Чтобы увеличить ограничение или квоту общедоступного IP-адреса для подписки, выполните следующие действия.

  1. Перейдите к портал Azure и выберите подписки, для которых выполняется операция.

  2. В разделе "Параметры" выберите "Использование и квоты". Задайте поставщику значение "Сеть" и при необходимости отфильтруйте его по региону кластера AKS.

  3. Найдите запись общедоступных IP-адресов. В той же строке нажмите кнопку "Создать новый запрос на поддержку".

    Снимок экрана: создание запроса на поддержку для увеличения квоты.

  4. На странице "Новый запрос на поддержку" укажите новое ограничение, которое требуется, а затем следуйте инструкциям по созданию запроса на поддержку.

    Снимок экрана: указание нового ограничения для общедоступных IP-адресов.

После изменения квоты повторите операцию, которая первоначально вызвала ошибку PublicIPCountLimitReached.

Свяжитесь с нами для получения помощи

Если у вас есть вопросы или вам нужна помощь, создайте запрос в службу поддержки или обратитесь за поддержкой сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.