Поделиться через


Ошибка: "Веб-сокет закрыт или не удается открыть"

В этой статье описывается, как устранить сообщение об ошибке "Веб-сокет закрыт или не удается открыть", которое запрещает microsoft Экземпляры контейнеров Azure подключаться к виртуальной сети.

Симптомы

При попытке подключиться к контейнеру из портал Azure вы получите следующее сообщение об ошибке:

Произошла следующая ошибка веб-сокета: ошибка: веб-сокет закрыт или не может быть открыт. Проверьте сетевое подключение и повторите попытку.

Причина

Брандмауэр или корпоративный прокси-сервер блокирует доступ к порту 19390. Этот порт необходим для подключения к Экземпляры контейнеров из портал Azure при развертывании групп контейнеров в виртуальных сетях.

Решение

Чтобы устранить эту ошибку, разрешите входящий трафик через TCP-порт 19390 в брандмауэре. По крайней мере убедитесь, что брандмауэр предоставляет доступ к этому порту для всех общедоступных IP-адресов клиента, к которым должен подключаться портал Azure.

В некоторых сценариях, когда корпоративный прокси-сервер блокирует порт 19390, разрешает этот порт для корпоративного прокси-сервера, а затем проверяет трафик с помощью вкладки "Сеть " в средствах разработчика браузера.

Свяжитесь с нами для получения помощи

Если у вас есть вопросы или вам нужна помощь, создайте запрос в службу поддержки или обратитесь за поддержкой сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.