Устранение неполадок при возникновении ошибки с кодом 0x80070005 и события с кодом 8207, когда отсутствуют данные для контейнера CN=Folder Hierarchies
Последнее изменение раздела: 2008-10-23
В данном разделе описаны причины появления в журнале административных событий или в журнале приложений при входе на компьютер с Microsoft Exchange Server 2007 следующего сообщения об ошибке:
Тип события: Ошибка Источник события: MSExchangeFBPublish Код события: 8207 Категория события: общие Описание: Не удалось обновить общую папку со сведениями о доступности на виртуальной машине Имя_машины. Номер ошибки — 0x80070005. |
Кроме того, пользователи Microsoft Office Outlook 2003 не могут получить доступ к общей папке, которая размещена на сервере Exchange, а база данных общих папок может быть отключена.
Причина
Ошибка возникает, когда в основной административной группе отсутствует контейнер CN=Folder Hierarchies или когда в контейнере CN=Folder Hierarchies для основной административной группы в Exchange 2007 не существует имя CN= Public Folders.
Решение
Чтобы устранить проблему, используйте одну или обе процедуры, описанные ниже.
Проверка существования контейнера CN=Folder Hierarchies
Нажмите кнопку Пуск, в поле Найти введите ADSI и выберите в разделе Программы пункт Редактор ADSI.
В области переходов редактора ADSI щелкните правой кнопкой мыши пункт Редактирование ADSI и выберите Подключение к.
В диалоговом окне Параметры подключения в группе Выберите известный контекст именования выберите в списке элемент Конфигурация и нажмите кнопку ОК.
Разверните узлы CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=First Organization, CN=Administrative Groups, CN=Exchange Administrative Group. Если контейнер CN=Folder Hierarchies не существует, его необходимо создать вручную. Для этого выполните действия, описанные ниже.
Щелкните правой кнопкой мыши элемент CN=Exchange Administrative Group, выберите команду Создать и выберите пункт Объект.
Выберите для класса значение msExchPublicFolderTreeContainer и нажмите кнопку Далее.
В поле Значение введите Folder Hierarchies и нажмите кнопку Далее.
Нажмите кнопку Готово.
Щелкните правой кнопкой мыши элемент CN=Folder Hierarchies, выберите команду Создать и выберите пункт Объект.
Выберите из списка пункт MSexchPFTree и нажмите кнопку Далее.
В поле Значение введите Public Folders, а затем нажмите кнопку Далее.
Нажмите кнопку Готово.
Нажмите кнопку Пуск и в меню последовательно выберите пункты Программы, Microsoft Exchange Server 2007 и Консоль управления Exchange.
В консоли управления Exchange разверните узел Конфигурация сервера и щелкните значок Почтовый ящик.
В области сведений щелкните правой кнопкой мыши элемент База данных общих папок и выберите команду Отключить базу данных. После отключения базы данных щелкните правой кнопкой мыши элемент База данных общих папок и выберите команду Подключить базу данных.
Проверка правильности местонахождения объекта CN=Public Folder
Нажмите кнопку Пуск, в поле Найти введите ADSI и выберите в разделе Программы пункт Редактор ADSI.
В области переходов редактора ADSI щелкните правой кнопкой мыши пункт Редактирование ADSI и выберите Подключение к.
В диалоговом окне Параметры подключения в группе Выберите известный контекст именования выберите в списке элемент Конфигурация и нажмите кнопку ОК.
Разверните узлы CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=First Organization, CN=Administrative Groups, CN=Exchange Administrative Group, CN=Folder Hierarchies.
Проверьте, существует ли элемент CN=Public Folders. Если элемент CN=Public Folders не существует, разверните узлы CN=Configuration, CN=Services, CN=Microsoft Exchange в редакторе ADSI.
Щелкните правой кнопкой мыши элемент CN=Public Folders и выберите пункт Переместить.
В диалоговом окне Перемещение разверните узлы CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=First Organization, CN=Administrative Groups, CN=Exchange Administrative Group, CN=Folder Hierarchies и нажмите кнопку ОК.
Нажмите кнопку Пуск, разверните меню Администрирование и выберите команду Службы.
В оснастке консоли управления (MMC) Службы щелкните правой кнопкой мыши узел Банк данных Microsoft Exchange и выберите команду Перезапустить.