Office 2013 не может проверять файлы, если у локальной сети нет доступа к Интернету или по некоторым виртуальным сетям
Эта статья была написана Уорреном Рат, инженером по эскалации поддержки.
В случаях, когда VPN вызывает эту проблему, мы обнаружили проблему в коде Windows (113100710844135), исправление выходит из стороннего VPN-клиента, который останавливает подключение к Интернету в Windows 7 с пакетом обновления 1 (SP1) или Windows Server 2008 R2 с пакетом обновления 1 (SP1). Мы проверили, что клиент Palo Alto Networks Global Protect Client и Juniper VPN работают с этим исправлением.
Клиенты используют сторонние решения VPN в Windows 7. Если клиенты переносятся в Office 2013 из более старой версии Office, они могут столкнуться с потерей функциональности в Office при подключении через VPN. Office 2013 взял зависимость от NLA (осведомленности о сетевом расположении), и некоторые решения VPN не работают должным образом с NLA. В частности, если программное обеспечение VPN не определяет шлюз по умолчанию. В этом случае NLA всегда сообщает, что клиент не подключен к Интернету. Это влияет на Office 2013, так как оно зависит от подключения к Интернету для некоторых функций. Например, на компьютере нет файла справки, и все справки находится в Интернете. Если клиент нажимает клавишу F1 в приложении Office 2013, он всегда получает ошибку, которая говорит, что они не подключены к Интернету при подключении через VPN.
Симптомы
Пользователи без полного доступа к Интернету могут не иметь возможности проверять файлы из клиента Office 2013, даже если между клиентом Office и сервером SharePoint есть хорошее подключение.
Причина
В Office 2010 и 2013 произошло изменение дизайна, где 2013 теперь требует подключения к Интернету для некоторых действий. Некоторые клиенты уже жаловались на эту проблему, и группа продуктов была проинформирована об ограничениях дизайна. (Но в настоящее время исправление в работе отсутствует, исправление может оказаться невозможным.
Основная проблема, как представляется, состоит в том, что Office 2013 имеет зависимость от NLA (осведомленности о сетевом расположении). NLA использует пробы, чтобы определить, имеет ли сетевое подключение "Доступ к Интернету". То, как это делается двумя способами.
- Он выполняет проверку DNS для
dns.msftncsi.com
. Ожидается конкретный ответ. Ответ должен быть131.107.255.255
. Если это так, то это правильная проверка DNS. - Он пытается подключиться
https://www.msftncsi.com
и пытается получить файл ncsi.txt. Внутри файла текст должен быть "Microsoft NCSI".
Если оба из указанных выше условий выполнены, подключение помечается как подключение к Интернету, если подключение не отмечено как отсутствие подключения к Интернету, а некоторые функции Office не будут работать.
Обходное решение
Вы можете настроить локальный сервер NCIS (индикатор состояния сетевого подключения) в локальной сети, который будет отвечать на запросы клиентов Office и разрешить работу функции Office.
Дополнительные сведения и инструкции см. в следующей статье: