Конфликт прокси-адресов при добавлении адреса электронной почты в Exchange Online
Симптомы
При попытке назначить прокси-адрес новому или существующему получателю почты в Exchange Online вы получите сообщение об ошибке, похожее на один из следующих примеров.
Ошибка 1
Прокси-адрес "SMTP:<конфликтующий SMTP-адрес>" уже используется "<domain.prod.outlook.com/Microsoft> Exchange Hosted Organizations/contoso.onmicrosoft.com/<forest>". Выберите другой прокси-адрес.
Ошибка 2
Вызов идентификатора Microsoft Entra ID был выполнен для синхронизации объекта между идентификатором Microsoft Entra и Exchange Online. Однако это не удалось. Подробное сообщение об ошибке: еще один объект с тем же значением для proxyAddresses свойства уже существует. ConflictingObject: PublicFolder_<GUID>.
Примерами получателя почты являются почтовый пользователь, почтовый ящик пользователя, общий почтовый ящик, группа рассылки, группа рассылки, группа Microsoft 365 и общедоступная папка с поддержкой почты (MEPF).
Причина
Причина 1
Первое сообщение об ошибке возникает, если объект с поддержкой почты в Exchange Online использует прокси-адрес, который требуется назначить.
Причина 2
Второе сообщение об ошибке возникает, если объект MEPF, имеющийся только в идентификаторе Microsoft Entra, использует прокси-адрес, который требуется назначить.
Решение
Решение первой ошибки заключается в проверке и удалении любого конфликтующего прокси-адреса в Exchange Online.
Разрешение второй ошибки заключается в том, чтобы проверить и удалить любой конфликтующий прокси-адрес в Exchange Online, а также проверить и удалить любой конфликтующий прокси-адрес в идентификаторе Microsoft Entra.
Используйте соответствующее разрешение в зависимости от сообщения об ошибке, которое вы получаете. Затем повторите попытку назначить прокси-адрес.
Проверьте и удалите конфликтующий прокси-адрес в Exchange Online
Выполните следующие действия, чтобы найти существующие объекты с поддержкой почты в Exchange Online, использующие конфликтующий прокси-адрес.
Чтобы вывести список всех получателей почты, использующих конфликтующий SMTP-адрес, выполните следующую команду:
Get-EXORecipient -ResultSize unlimited | Where-Object {$_.EmailAddresses -match "<conflicting SMTP address>"} | fl Name, RecipientType, EmailAddresses
Если вы не знаете точный SMTP-адрес, выполните следующую команду:
Get-EXORecipient -ResultSize unlimited | Where-Object {$_.EmailAddresses -match "<partial conflicting SMTP address>"} | fl Name, RecipientType, EmailAddresses
Прокси-адрес можно назначить только одному объекту за раз. После определения того, какой объект находится в конфликте, удалите или измените прокси-адрес, связанный с этим объектом.
Например, если объект является общедоступной папкой с поддержкой почты, выполните следующую команду, чтобы отключить общедоступную папку, чтобы освободить используемый адрес электронной почты:
Get-MailPublicFolder -ResultSize Unlimited | Where-Object {$_.EmailAddresses -match "<conflicting SMTP address>"} | Disable-MailPublicFolder
Проверьте и удалите конфликтующий прокси-адрес в идентификаторе Microsoft Entra
Внимание
Для этого разрешения требуется локальный сервер с установленным Microsoft Entra Connect. Если локальная инфраструктура отключена, обратитесь к служба поддержки Майкрософт.
Выполните следующие действия, чтобы проверить и удалить из Microsoft Entra любые MEPFs, использующие конфликтующий прокси-адрес. Для этих действий требуется локальный сервер, на котором выполняется Microsoft Entra Connect версии 2.0 или более поздней версии.
Найдите конфликтующий прокси-адрес во всех локальных MEPF, выполнив следующую команду в локальной оболочке управления Exchange (EMS):
Get-MailPublicFolder -ResultSize Unlimited | Where-Object {$_.EmailAddresses -match "<conflicting SMTP address>"}
Для каждого локального mePF, определенного на шаге 1, удалите конфликтующий SMTP-адрес, выполнив следующую команду в локальной среде EMS:
Set-MailPublicFolder -Identity <public folder name or GUID> -EmailAddresses @{remove="<conflicting SMTP address>"} -EmailAddressPolicyEnabled:$false
На этом шаге удаляются конфликты адресов прокси-сервера на локальной стороне, чтобы убедиться, что они не синхронизированы с идентификатором Microsoft Entra или Exchange Online.
Если вы удалили конфликтующий SMTP-адрес из любого локального mePF на шаге 2, дождитесь следующей запланированной синхронизации на сервере Microsoft Entra Connect или вручную запустите цикл синхронизации, выполнив следующую команду PowerShell:
Start-ADSyncSyncCycle -PolicyType Delta
Синхронизация должна удалить конфликтующий SMTP-адрес из идентификатора Microsoft Entra.
Если вы не нашли конфликтующий SMTP-адрес в локальной среде MEPF или если синхронизация не удалила конфликтующий SMTP-адрес из идентификатора Microsoft Entra, выполните поиск идентификатора Microsoft Entra для MEPFs с конфликтующим SMTP-адресом. Чтобы найти MEPFs в идентификаторе Microsoft Entra, используйте командлет Get-ADSyncToolsAadObject PowerShell на сервере Microsoft Entra Connect. При поиске не учитывается регистр. Включите префикс smtp:, если указать SMTP-адрес.
$mailEnabledPublicFolders = Get-ADSyncToolsAadObject -SyncObjectType "PublicFolder" -Credential (Get-Credential)
$conflictingSmtpAddress = "smtp:<conflicting SMTP address>"
$mailEnabledPublicFolders | Where-Object {$_.ProxyAddresses -icontains $conflictingSmtpAddress} | Select SourceAnchor
Результаты поиска предоставляют SourceAnchor для каждого MEPF, соответствующего критериям поиска.
Для каждого MEPF, определенного на шаге 4, удалите MEPF из идентификатора Microsoft Entra с помощью командлета Remove-ADSyncToolsAadObject .
SourceAnchor
Укажите значение MEPF в формате Base64.$conflictingSourceAnchor= "SourceAnchor value"
Remove-ADSyncToolsAadObject -SourceAnchor $conflictingSourceAnchor -SyncObjectType "PublicFolder" -Credentials (Get-Credential)
Пример использования командлета см . в примере remove-ADSyncToolsAadObject 2.
Повторно выполните поиск идентификатора Microsoft Entra с шага 4. На этот раз результаты поиска не должны возвращать метаданные.