Устранение неполадок с API подготовки для входящих подключений
Введение
В этом документе рассматриваются часто возникающие ошибки и проблемы с API подготовки входящего трафика и способы их устранения.
Сценарии устранения неисправностей
Недопустимый формат данных
Описание проблемы
- Вы получаете сообщение
Invalid Data Format
об ошибке с кодом ответа HTTP 400 (недопустимый запрос).
Возможные причины
- Вы отправляете допустимый массовый запрос согласно спецификациям API / bulkUpload , но не задано значение "Тип контента" заголовка HTTP-запроса
application/scim+json
. - Вы отправляете массовый запрос, который не соответствует спецификациям API подготовки /bulkUpload .
Решение.
- Убедитесь, что HTTP-запрос имеет заголовок, заданный
Content-Type
для значенияapplication/scim+json
. - Убедитесь, что полезные данные массового запроса соответствуют спецификациям API /bulkUpload .
Нет ничего в журналах подготовки
Описание проблемы
- Вы отправили запрос в конечную точку API подготовки /bulkUpload и получили код ответа HTTP 202, но в журналах подготовки нет данных, соответствующих вашему запросу.
Возможные причины
- Приложение подготовки на основе API приостановлено.
- Служба подготовки пока не обновляет журналы подготовки с подробными сведениями об обработке массового запроса.
- Состояние локального агента подготовки неактивно (если вы выполняете подготовку входящих пользователей на основе API для локальная служба Active Directory).
Решение.
- Убедитесь, что приложение подготовки запущено. Если он не запущен, выберите параметр меню "Начать подготовку " для обработки данных.
- Включите состояние локального агента подготовки, перезагрузив локальный агент.
- Ожидается 5–10-минутная задержка между обработкой запроса и записью в журналы подготовки. Если клиент API отправляет данные в конечную точку API подготовки /bulkUpload, введите задержку времени между вызовом запроса и запросом журналов подготовки.
Запрещенный код ответа 403
Описание проблемы
- Вы отправили запрос в конечную точку API подготовки /bulkUpload и получили код ответа HTTP 403 (запрещено).
Возможные причины
- Разрешение
SynchronizationData-User.Upload
Graph не назначается клиенту API.
Решение.
- Назначьте клиенту API разрешение
SynchronizationData-User.Upload
Graph и повторите операцию.
Слишком много запросов 429 кода ответа
Конечная точка API bulkUpload применяет следующие ограничения регулирования и возвращает код ответа 429, если эти ограничения нарушены.
40 вызовов API в 5 секунд — если количество вызовов выходит за рамки этого ограничения в 5-секундном диапазоне, клиент получает ответ 429. Один из способов избежать этого заключается в приостановке отправки запроса с помощью задержек в логике отправки запроса клиента.
6000 вызовов API в течение 24 часов — если количество вызовов выходит за рамки этого ограничения, клиент получает ответ 429. Один из способов предотвратить это заключается в том, чтобы убедиться, что массовая загрузка SCIM оптимизирована для использования максимальной 50 записей на вызов API. С помощью этого подхода можно отправлять записи 300K каждые 24 часа.
Несанкционированный код ответа 401
Описание проблемы
- Вы отправили запрос в конечную точку API подготовки /bulkUpload и получили код ответа HTTP 401 (несанкционированный). Код ошибки отображает "InvalidAuthenticationToken" с сообщением о том, что срок действия маркера доступа истек или еще не действителен.
Возможные причины
- Срок действия маркера доступа истек.
Решение.
- Создайте новый маркер доступа для клиента API.
Задание вводит состояние карантина
Описание проблемы
- Вы только что запустили приложение подготовки и находится в состоянии карантина.
Возможные причины
- Перед началом задания вы не задали сообщение электронной почты уведомления.
Разрешение. Перейдите в пункт меню "Изменение подготовки ". В разделе "Параметры" установлен флажок "Отправить уведомление по электронной почте" при возникновении сбоя и поле для ввода сообщения электронной почты уведомления. Установите флажок, укажите сообщение электронной почты и сохраните изменения. Щелкните "Перезапустить подготовку", чтобы выйти из карантина.
Создание пользователя — недопустимое имя участника-пользователя
Описание проблемы: сбой подготовки пользователей. В журналах подготовки отображается код ошибки: AzureActiveDirectoryInvalidUserPrincipalName
Решение.
- Перейдите на страницу "Изменить сопоставления атрибутов ".
UserPrincipalName
Выберите сопоставление и обновите его, чтобы использовать функциюRandomString
.- Скопируйте и вставьте это выражение в поле выражения:
Join("", Replace([userName], , "(?<Suffix>@(.)*)", "Suffix", "", , ), RandomString(3, 3, 0, 0, 0, ), "@", DefaultDomain())
Это выражение устраняет проблему, добавляя случайное число к значению имени участника-пользователя, принятому идентификатором Microsoft Entra.
Сбой создания пользователя — недопустимый домен
Описание проблемы: сбой подготовки пользователей. В журналах подготовки отображается сообщение об ошибке, которое указывает domain does not exist
.
Решение.
- Перейдите на страницу "Изменение сопоставлений атрибутов ".
UserPrincipalName
Выберите сопоставление и скопируйте и вставьте это выражение в поле ввода выражения:Join("", Replace([userName], , "(?<Suffix>@(.)*)", "Suffix", "", , ), RandomString(3, 3, 0, 0, 0, ), "@", DefaultDomain())
Это выражение устраняет проблему путем добавления домена по умолчанию к значению имени участника-пользователя, принятому идентификатором Microsoft Entra.