Поделиться через


WSUS Installation Fails with No Specified Error and ‘Tools’ Folder is Missing after WSUS Installation

Symptoms

  • When installing WSUS through the Add Roles and Features Wizard (ARW), the Post-Installation task fails and the generated log folder (*.tmp) is empty, AND
  • The Tools folder is missing after WSUS was installed. Note: By default, the Tools folder is installed to the following location: %SystemDrive%\Program Files\Update Services\Tools

 

This behavior has been seen when:

  • Uninstalling WSUS
  • Manually deleting WSUS folder: %SystemDrive%\Program Files\Update Services
  • Manually deleting WSUS registry keys: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Update Services
  • Re-installing WSUS

 

Root Cause

When uninstalling WSUS Role via ARW the “API and PowerShell cmdlets” feature is not uninstalled by default (unless explicitly selected by the user). Deleting the remaining WSUS folders and registry keys leaves the server in a bad state and the re-installation fails because it is expecting this feature to be already installed.

 

Workaround

Uninstall all the WSUS roles and features and re-install WSUS.

 

Workaround 1: To uninstall WSUS roles and features using Windows PowerShell

  1. In PowerShell, review features installed by calling: Get-WindowsFeature UpdateServices*
  2. To remove features, call: Uninstall-WindowsFeature <featureName>

 

Workaround 2: To uninstall WSUS roles and features using the Server Manager Console

In Server Manager, launch Remove Roles and Features Wizard (RRW), unselect items to be uninstalled, and complete the Wizard:

  1. In Server Roles tab unselect ‘Windows Server Update Services’ option
  2. In Features tab unselect ‘Remote Server Administration Tools -> Role Administration Tools -> Windows Server Update Services Tools’ option

 

We recommend restarting the server to ensure that all WSUS components are removed. After uninstalling WSUS roles and features, you may reinstall the WSUS roles and features.

 

To reinstall WSUS, launch the Add Roles and Features Wizard and then select the “Windows Server Update Services” option. You may optionally reinstall the Windows Server Update Services Tools. After the ARW completes successfully, you may run the WSUS post-installation tasks.

Comments

  • Anonymous
    January 01, 2003
    very good article indeed thank you
  • Anonymous
    January 01, 2003
    This worked for me. Thanks.
  • Anonymous
    April 08, 2014
    227 Microsoft Team blogs searched, 58 blogs have new articles. 225 new articles found searching from
  • Anonymous
    April 17, 2014
    Thank you very much. I was trying to do a clean reinstall of WSUS ran into this problem after uninstalling and doing the manual deletions. Your work arounds took me a couple ties because I when I clicked remove WSUS in the ARW it has a pop up windows to remove features related to WSUS. I though this was your step 2 but it is not. I still needed to do your step 2 and once I did it worked. Thank you again this has fix several days of frustrations
  • Anonymous
    December 03, 2014
    Awesome, it took forever to find out root cause. Thank you for article
  • Anonymous
    December 19, 2014
    Guys for some reason I am unable to install WSUS on my Server 2012 R2. It keeps error-ing out saying Post Installation Failed. This is a brand new server, new install. The only thing on it is Symantec. What am I doing wrong? I got machines I cannot update...so frustrating.
  • Anonymous
    March 31, 2015
    The comment has been removed
  • Anonymous
    April 16, 2015
    The comment has been removed
  • Anonymous
    June 12, 2015
    thank you

    http://www.kodes.com Hiphop, Rap, Ceza, sagopa, Kolera

    http://www.gekkog.com Hiphop, Rap, Gekko G

    http://www.maskanimasyon.com Animasyon
  • Anonymous
    August 13, 2015
    Thanks for the its much appreciated..
    http://www.kaderim.net
  • Anonymous
    October 01, 2015
    THANK YOU!! This is the solution that I've been looking for! Now, if I can only figure out why my clients are not showing up in WSUS, I'll be ecstatic!
  • Anonymous
    November 20, 2015
    Thanks, this has been driving me up the wall
  • Anonymous
    November 20, 2015
    Thanks, this has been driving me up the wall
  • Anonymous
    February 26, 2016
    Thanks!
  • Anonymous
    April 26, 2016
    Old but gold thanks for this
  • Anonymous
    May 05, 2016
    I wasted days trying to find a cause. Thanks for the excellent post!
  • Anonymous
    August 05, 2016
    The comment has been removed
    • Anonymous
      May 05, 2017
      The post-install operation works on the database, so the user running it must be an administrator of the SUSDB. Whether it's SQL or WID, if they cannot access and modify the SUSDB, then post-install will not work as expected.