Поделиться через


2017 年 10 月にリリースされた Windows 10 1607 / 1703 向け更新プログラム適用後に OS 起動不可になる問題について (SCCM)

皆さま、こんにちは。System Center Configuration Manager サポート チームです。
2017 年 10 月にリリースされた Windows 10 1607 / 1703 向け更新プログラム KB4041691 および KB4041676  適用後に OS 起動不可になる問題について、次の通りご案内いたします。

この度は弊社更新プログラムの問題により、ご迷惑をおかけいたしましたことを、深くお詫び申し上げます。

対象製品

WSUS / System Center Configuration Manager
Windows 10 1607 / 1703, Windows Server 2016

概要

WSUS または System Center Configuration Manager から配信された KB4041691 および KB4041676   の「累積更新プログラム」と「差分更新プログラム」が同時にインストールされたマシンにおいて、再起動後に OS が起動できない問題が発生する可能性があります。インターネットの Windows Update からのみ更新プログラムを取得しているマシンは本問題の影響を受けません。

原因

日本時間の 2017 年 10 月 11 日の午前 8 時まで、KB4041691 および KB4041676  の「累積更新プログラム」と「差分更新プログラム」を WSUS 向けに公開していたことによります。この期間に同期を行った WSUS サーバーにおいては「累積更新プログラム」と「差分更新プログラム」が配信可能となります。これら 2 つの更新プログラムを WSUS または System Center Configuration Manager から同時に配信した場合、本問題が発生します。

影響

KB4041691 および KB4041676   の「累積更新プログラム」と「差分更新プログラム」がインストールされている場合、再起動後に OS が起動できない問題が発生する可能性があります。更新プログラムがインストールされているかどうかは、「設定」->「更新とセキュリティ」->「Windows Update」画面の「更新の履歴」よりご確認いただけます。

対処方法

・System Center Configuration Manager 側の対処方法

System Center Configuration Manager 管理コンソールの「すべてのソフトウェア更新プログラム」に KB4041691 および KB4041676 の「差分更新プログラム」が表示されていなければ、特に対処する必要はありません。表示されている場合は、「ソフトウェア更新プログラムの同期」を実施するか、WSUS 管理コンソールにて、KB4041691 および KB4041676   の「差分更新プログラム」を右クリックして、[拒否] をクリックします。なお、2017 年 10 月 11 日 (水曜日) の午前 9 時以降に WSUS が同期されている場合、自動的に「拒否済み」となり、System Center Configuration Manager 管理コンソールには表示されません。以下の画面ショットのように「差分更新プログラム」が「拒否済み」の状態となっていれば、対処は完了しています。

・クライアント側の対処方法

KB4041691 および KB4041676  の「差分更新プログラム」がインストールされていなければ、特に対処を実施して頂く必要はありません。「差分更新プログラム」がインストールされた場合の対処方法につきましては、次の技術情報をご確認ください。 Windows デバイスは、10 月 10日のバージョンの KB4041676 または公開の問題が含まれている KB4041691 をインストールした後のブートに失敗する可能性があります。

「差分更新プログラム」がインストールされているが、再起動前の状態の場合は、「シナリオ 2」の対処方法を実施してください。再起動後に OS が起動できない状態の場合は、「シナリオ 3」の対処方法を実施してください。

(補足)
上記技術情報に記載の内容をわかりやすくまとめ直したものについて、次にご紹介いたします。

シナリオ 2. 「累積更新プログラム」と「差分更新プログラム」がインストールされているが、まだ再起動していない場合

コントロールパネルより、「累積更新プログラム」と「差分更新プログラム」の両方をアンインストールしてください。

シナリオ 3. 再起動し、起動できない状態になった場合

以下の手順でアンインストールを行います。

1. 何度か起動に失敗すると、青い自動修復画面が表示されますので、[詳細オプション] をクリックします。

2. [トラブルシューティング] – [詳細オプション] - [コマンド プロンプト] をクリックします。

3. コマンドプロンプトで以下のコマンドを実行し、Software ハイブをマウントします。
> reg load hklm\temp <OS ドライブ>\windows\system32\config\software
実行例: reg load hklm\temp C:\windows\system32\config\software

4. 以下のコマンドを実行し、レジストリ キーを削除します。
なお、環境によってはキーは存在しない場合がございますので、その際は次の手順に進んでください。
> reg delete “HKLM\temp\Microsoft\Windows\CurrentVersion\Component Based Servicing\SessionsPending” /v Exclusive
> reg unload HKLM\temp

5. 以下のコマンドを実行し、パッケージ情報を取得します。
> dism /Image:<OS ドライブ> /Get-Packages
例: Dism /Image:C:\ /Get-Packages

6. インストール済みのパッケージの一覧が表示されますので、状態が [保留中] となっているパッケージ ID を確認します。
出力例:
パッケージ ID : Package_for_RollupFix~31bf3856ad364e35~amd64~~15063.674.1.8
状態 : インストールの保留中
リリースの種類 : Security Update
インストール時刻 :

7. 手順 6 のパッケージ ID を使用して、以下のコマンドを実行し、削除します。
> Dism /Image:<OS ドライブ> /Remove-Package /PackageName:<パッケージ ID>
例: Dism /Image:C:\ /Remove-Package /PackageName:Package_for_RollupFix~31bf3856ad364e35~amd64~~15063.674.1.8

8. 保留中のパッケージをすべて削除しましたら、コマンドプロンプトを終了し、[続行] をクリックして再起動します。