Поделиться через


Exchange 2010 SP1 Unified Messaging integration with Nortel CS1000

 

With the release of Exchange 2010 SP1 we have seen some issues integrating with Nortel CS 1000. Nortel CS 1000 is currently not part of the Telephony Advisory Program and not certified for Exchange 2010 & 2010 SP1. It is currently supported only when it connects to Exchange UM through one of the supported IP gateways - Dialogic DMG, Audiocodes, etc.

 

BACKGROUND

To connect a call to UM the gateway first connects to it the UMService running on port 5060\5061 and then the call is immediately transferred to the UMWorkerProcess on port 5065\5067. You can know more about the process here.  This transfer is basically a redirect done by SIP message 302 Moved Temporarily containing a Contact header that tells the gateway where to connect to the UMWorkerProcess. 

 

ISSUE

You may experience an issue where once a user connected to Nortel CS1000 calls into Exchange UM he hears dead air. The call is never connected to any of the UM features - voicemail\ subscriber access\ auto attendant. We have seen this issue with version 5.x and 6.x.

 

CAUSE

After investigation we have found that at times Nortel CS 1000 is not able to understand this Contact header needed to route the request to UMWorkerProcess. This occurs when the Contact header contains an optional maddr parameter (multicast address) containing the domain that needs to be communicated to continue this call.

 

Contact: <sip:3213;phone-context=ping@microsoft.com:5065;maddr=microsoft.loc>

 

Now, this maddr parameter is added to the Contact header by UM only if the incoming INVITE into UM contains the optional maddr parameter in the Request line -

 

Request-Line: INVITE sip:3213;phone-context=ping@microsoft.com;maddr=10.10.10.1;transport=tcp SIP/2.0

 

If you view this in Network Monitor\ Wireshark you will see that the second INVITE into the UM worker process is never received at the UM server -

 

 

Instead of -

 

 The result will be dead air/unable to connect the call.

 

SOLUTION

Audio Codes, Dialogic among other supported gateways give the ability to either strip the optional maddr parameter or can route the traffic for that domain to a particular gateway. They have also been certified to work with Exchange UM 2010\2010 SP1. It is advised that a supported gateway be introduced to connect with Exchange UM 2010 SP1 till we are able to certify Nortel CS 1000.

Comments

  • Anonymous
    January 01, 2003
    Thanks Paul and dgjlee, We totally understand where you guys are coming from and we thank you for your continued loyalty.Microsoft is doing everything possible to get this working as soon as possible. I will personally update this blog when there is an update. Thanks, Jigar

  • Anonymous
    January 01, 2003
    I didn't open one Jigar as I stumbled across your blog post first. I am on an EA agreement so will raise one tomorrow and get it escalated. I appreciate your interest in this.

  • Anonymous
    January 01, 2003
    Just to expand on Paul's post How is it determined that Avaya should approach Microsoft and engage in the TAP program, rather than MS engaging with Avaya on their DEV connect program? I’m not precious about this but any “stand-off” leaves customers like myself in limbo. We have been using UM on 2007 for a long time now but it’s the move to 2010 SP1 that has caused us an issue. . I’m sure you can understand that after spending a lot of money on IP PBX, we expect to be able to integrate via SIP directly and not have to spend money on third party sip gateways when we already have one. We are just about to undertake a upgrade to new hardware and release 7.5 which I believe moves us closer to the Aura world.

  • Anonymous
    January 01, 2003
    I have bought this issue up with Avaya and their stance is that MS should be certifying this on their Dev connect program, rather than Avaya certifying against the MS TAP program. Big boys pushing each other around while customers suffer!!!! We are going to release 7.5 for different reasons and their are no guarantees this will fix the issue. In fact, due to the nature of this issue, I doubt it will be fixed. As a customer, I am annoyed with both companies for not getting this sorted.

  • Anonymous
    January 01, 2003
    Hi CitizenK, Thank you for visiting my blog. We would be eager to know if R7.0 changes this. Please keep us posted. Thanks, Jigar

  • Anonymous
    January 01, 2003
    Hello Everyone, This has been officially released through Avaya's DevConnect program - devconnect.avaya.com/.../UM2010-CS1K75.pdf. I have not personally tested this yet, but the above link may help. I really appreciate your patience. Please let me know if anyone has already tested this. Thanks, Jigar

  • Anonymous
    January 01, 2003
    Hello, David - I am doing fine, hope the same for you. We are still working diligently to get this interop working. Nothing concrete that I can report here. Thank you so much for everyones patience. Thanks, Jigar

  • Anonymous
    January 01, 2003
    Hello djlee, Do you have a case with Microsoft? If yes, please escalate it to me and I can use your business case to further push for a resolution. Thanks, Jigar

  • Anonymous
    January 01, 2003
    Hello dgjlee, We are also planning an upgrade to 7.5 as well.  Have you brought this issue up to Avaya in your discussions for the implementation of this new version?  Does 7.5 have any promise of being able to connect to 2010 SP1 without a new gateway?

  • Anonymous
    January 01, 2003
    Hi Jigar, Has there been any progress? Any time-scales? Any beta patches we can test? This is the only thing holding up a 1000 user migration I am trying to do.

  • Anonymous
    January 01, 2003
    Hello Nicholas, Thanks for visiting my post. Unfortunately at this time I still dont have any updated news. Thanks for your loyalty. I will keep you guys posted. Thanks, Jigar

  • Anonymous
    January 01, 2003
    Hello Rick, Thanks for visiting my blog. that is unfortunate to here. Again, Microsoft doing all it can to get this interop working soon. We thank you for your persistence. Stay tuned. Thanks, Jigar

  • Anonymous
    January 01, 2003
    Hello Im_Always_Smiling and Ahmed, Thanks for visiting my post. At this point I do not have anything to announce. We are still doing out best to get this interop certified. We apologize for any inconvenience and thank you for your patience. Thanks, Jigar

  • Anonymous
    January 01, 2003
    David, Thanks for visiting my blog. Unfortunately, at this time Nortel CS1000 is till not part of the Telephony Advisory Program. We are working diligently to get Nortel CS 1000 certified. When that happens I will update the blog. Thanks, Jigar

  • Anonymous
    January 01, 2003
    Hi Jigar, Hope your well. How are the negotiations with Avaya going to get the platform certified?

  • Anonymous
    January 01, 2003
    Hello Jigar, Thanks for this post as well.  We are quite reluctant to invest further in 3rd party hardware as this really is a burden from a support perspective as well.  Understanding that the CS1000 is not part of the list of supported configurations, why would Microsoft release a service pack upgrade to this system knowing the large number of users that are either currently using Unified Messaging, or are planning large integrations.  The biggest challenge being faced as well is that even to get any support on the system, Microsoft expects that you have performed all the latest updates.  So even when we had issues pre SP1, we could not even get support on this.  This limits a lot of possibilities for our organization and will prevent us from switching over to this system, espescially if this is the type of issue will come up with every service pack or roll up release. Is there any time lines as to when this will be supported on the Avaya/Nortel PBX? Thanks again, Paul

  • Anonymous
    January 01, 2003
    Sorry Paul, I meant to add that Avayas response also said "buy a third party gateway". I am sure you will agree this a totally unacceptable response.

  • Anonymous
    February 24, 2011
    When will this be certified and supported for CS1000 release 5.5 and up to 7.5?

  • Anonymous
    March 03, 2011
    Hi Jigar, Thanks for responding to my post. I am amazed that such a large company as Avaya has not entered the widely used CS1000 into the TAP program! I am a little bemused by this and I will be be pushing my partner and Avaya account manager on this. If their is anything I can do to help Microsoft in testing or trying beta patches that may resolve this, please let me know as this issue is holding up a 1000 user migration to 2010.

  • Anonymous
    April 19, 2011
    I have heard that the CS1000 will actually work once it is upgraded to firmware release 7.0 and above. Albeit this doesn't necessarily qualify it for certification and support with Exchange 2010.

  • Anonymous
    June 20, 2011
    We are on release CS1000 release 7.0 and still have this issue. We are planning on going to 7.5 soon but I do not foresee it fixing this issue.

  • Anonymous
    August 01, 2011
    Any updates on this - we have a customer with the same issue

  • Anonymous
    August 02, 2011
    Hi, I would reccomend you look at seeing if the CS1000 has something called proxy route for the SIP stuff. This was how we resolved the redirect issue on our Avaya Communications Manager, by using a proxy location pointint it to the trunk of the UM Server. Rgds StickeyTape

  • Anonymous
    September 27, 2011
    Any update on the certification yet?  We too are going to Exchange 2010 and have a single UM server and CS1000.  Migration plan for second week in October.  Need it to be certified.  Any info would be helpful.  Thanks.

  • Anonymous
    October 23, 2011
    Same here as "Im_Always_Smiling".   Sad to follow in Microsoft's steps and end up nowhere :-(

  • Anonymous
    November 28, 2011
    Any updates?

  • Anonymous
    January 12, 2012
    Well, it's nearly been a year since this blog post. Shocking service from Avaya and MS on this. Two massive companies with the resources to get sorted, leave their customers in limbo.

  • Anonymous
    January 25, 2012
    The comment has been removed

  • Anonymous
    January 25, 2012
    Did some more research and found this document was released yesterday support.avaya.com/.../100155631

  • Anonymous
    July 05, 2013
    The comment has been removed