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SessionHasLoggedOff ocorre durante uma execução de fluxo da área de trabalho conectada à nuvem

Este artigo fornece etapas de solução de problemas para um problema em que você recebe o código de erro SessionHasLoggedOff durante uma execução de fluxo da área de trabalho no ambiente de nuvem no Microsoft Power Automate.

Sintomas

Durante a execução de um fluxo da área de trabalho no ambiente de nuvem, você recebe o SessionHasLoggedOff código de erro com a mensagem "A sessão foi desconectada durante a execução da execução".

{
    "error":{
        "code": "SessionHasLoggedOff",
        "message": "The session logged off during run execution."
    }    
}

Motivo

O código de erro ocorre porque a sessão do Windows que executa o fluxo da área de trabalho é desconectada pelo sistema. Esse problema pode ocorrer devido a ações manuais do usuário ou software de terceiros em execução em sua máquina.

Etapas para solucionar problemas

Para investigar o problema, siga estas etapas:

  1. Verifique os scripts personalizados: verifique se não há scripts personalizados (como arquivos em lote ou scripts do PowerShell) no fluxo da área de trabalho que possam fazer com que a sessão saia ou a máquina seja reiniciada.

  2. Verifique as configurações de política de grupo: verifique se nenhuma configuração de política de grupo está configurada para sair da sessão da área de trabalho remota devido a limites de tempo. Você pode verificar essas configurações abrindo o Editor de Diretiva de Grupo Local e navegando até Modelos >Administrativos de Configuração>do Computador, Componentes do Windows,>Serviços de Área de Trabalho Remota, Limites>de Tempo de Sessão.

  3. Observe o tempo de conclusão: Registre o tempo em que a execução do fluxo da área de trabalho for concluída.

  4. Examine os logs do Visualizador de Eventos do Windows:

    1. Vá para o computador que executa o fluxo e abra o Visualizador de Eventos do Windows.

    2. Navegue até Logs>de aplicativos e serviços Microsoft>Windows>TerminalServices-LocalSessionManager para verificar os logs do gerenciador de sessão local.

    3. Procure logs correspondentes ao tempo de saída, usando o tempo de conclusão como referência. Verifique os logs desse momento até vários minutos antes.

  5. Identifique a causa:

    • Procure indicações do que pode causar a desconexão da sessão, como processos em execução na sessão 0 ou ações do usuário.
    • Se você vir um evento com a ID do Evento 40, isso indica que a sessão está desconectada com um código de motivo.
  6. Verifique o software de terceiros: Se a desconexão for causada por software de terceiros, verifique os logs ao redor do carimbo de data/hora da desconexão no aplicativo de logs>do Windows para ver se o aplicativo registrou alguma informação relevante.