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MaxRDSessionDurationReached ou SessionHasLoggedOffWithMaxIdleTime ocorre durante uma execução de fluxo da área de trabalho

Este artigo fornece uma resolução para códigos de erro que ocorrem durante uma execução de fluxo da área de trabalho em um ambiente de nuvem no Microsoft Power Automate.

Sintomas

Quando você executa um fluxo da área de trabalho em um ambiente de nuvem no Power Automate, a execução do fluxo pode falhar com um dos códigos de erro que indica o nome do valor do Registro e seu caminho específico do Registro.

{ 
    "error":{
        "code": "MaxRDSessionDurationReached",
        "message": "The session 5 duration (1856000 milliseconds) exceeded the one set in registry for MaxConnectionTime with value 1200000 in registry path Software\Policies\Microsoft\Windows NT\Terminal Service."
    } 
}
{ 
    "error":{
        "code": "SessionHasLoggedOffWithMaxIdleTime",
        "message": "The session 5 duration (1856000 milliseconds) exceeded the one set in registry for MaxIdleTime with value 1200000 in registry path Software\Policies\Microsoft\Windows NT\Terminal Service."
    } 
}

Causa

A mensagem de erro indica que a sessão da área de trabalho remota foi desconectada porque excedeu o limite de tempo especificado no registro (MaxConnectionTime ou MaxIdleTime). Esse problema ocorre quando o limite de tempo da sessão na configuração do Registro é menor do que o tempo necessário para concluir o fluxo da área de trabalho.

Solução

Para resolver esse problema, entre em contato com o administrador para alterar as configurações usando uma das opções.

Opção 1: por meio do Editor de Diretiva de Grupo Local

Verifique as configurações de política de grupo para garantir que nenhuma configuração esteja definida para sair da sessão da área de trabalho remota devido a limites de tempo. Você pode fazer isso abrindo o Editor de Diretiva de Grupo Local e navegando até Configuração do Computador>, Modelos>Administrativos, Componentes do Windows,>Serviços de Área de Trabalho Remota, Limites de Tempo de>Sessão.

  • Se a mensagem de erro apontar para o valor do Registro MaxConnectionTime , verifique a configuração Definir limite de tempo para sessões ativas dos Serviços de Área de Trabalho Remota. Se estiver habilitado, desabilite-o ou defina o valor do limite de sessão ativa como Nunca.
  • Se a mensagem de erro apontar para o valor do Registro MaxIdleTime, verifique a configuração Definir limite de tempo para sessões ativas, mas ociosas, dos Serviços de Área de Trabalho Remota. Se estiver habilitado, desabilite-o ou defina o valor do limite de sessão ativa como Nunca.

Opção 2: através do Editor do Registro

Abra o Editor do Registro e localize o nome do valor do Registro na mensagem de erro no caminho do Registro especificado em Computador\HKEY_LOCAL_MACHINE\.

Por exemplo, Computador\HKEY_LOCAL_MACHINE\Software\Políticas\Microsoft\Windows NT\Terminal Service

Se o valor do Registro MaxConnectionTime ou MaxIdleTime existir, defina-o como 0 (zero), o que significa que ele é ilimitado.

Observação

O valor do Registro também pode ser excluído ou definido como um valor maior que o tempo máximo de execução do fluxo da área de trabalho.

Nome do valor do Registro Descrição
Tempo de Conexão Máxima Especifica o tempo máximo (em milissegundos) que uma sessão de área de trabalho remota pode permanecer ativa, independentemente da atividade.
MaxIdleTime Especifica o tempo máximo (em milissegundos) que uma sessão de área de trabalho remota pode permanecer ociosa (sem entrada do usuário, como atividade de teclado ou mouse) antes de ser desconectada.