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Erro AADSTS750054 – SAMLRequest ou SAMLResponse deve estar presente como parâmetro de cadeia de caracteres na solicitação HTTP para a associação de redirecionamento SAML

Este artigo descreve um problema no qual você recebe a mensagem de erro "Erro AADSTS750054 - SAMLRequest ou SAMLResponse deve estar presente como parâmetros de cadeia de caracteres de consulta na solicitação HTTP para associação de redirecionamento SAML." ao tentar entrar em um aplicativo configurado de logon único (SSO) baseado em SAML que foi integrado à ID do Microsoft Entra.

Sintomas

Você recebe um erro AADSTS750054 ao tentar entrar em um aplicativo que foi configurado para usar a ID do Microsoft Entra para gerenciamento de identidades usando o SSO baseado em SAML.

Motivo

O Microsoft Entra ID não pôde identificar a solicitação SAML dentro dos parâmetros de URL na solicitação HTTP. Isso pode acontecer se o aplicativo não estiver usando a associação de redirecionamento HTTP ao enviar a solicitação SAML para a ID do Microsoft Entra.

Resolução

O aplicativo precisa enviar a solicitação SAML codificada no cabeçalho do local usando a associação de redirecionamento HTTP. Para obter mais informações sobre como implementá-la, leia a seção sobre Associação de redirecionamento HTTP no Documento de especificação de protocolo SAML.

Na maioria das vezes, o erro é devido a um dos seguintes problemas:

  1. Certifique-se de que o logon único esteja habilitado no lado do aplicativo.
  2. O aplicativo deve oferecer suporte ao logon único iniciado pelo provedor de serviços (às vezes conhecido como SSO iniciado pelo SP). Ao inserir uma URL de entrada para um aplicativo que oferece suporte apenas ao logon único iniciado pelo provedor de identidade, pode levar a uma devolução do aplicativo sem uma resposta SAML.
  3. Verifique se a URL de logon está configurada corretamente.

Usando a função SSO de teste no centro de administração do Microsoft Entra

O centro de administração do Microsoft Entra pode ajudá-lo a solucionar erros de configuração do SAML.

Captura de tela do recurso de teste de SSO no centro de administração do Microsoft Entra.

  1. No centro de administração do Microsoft Entra, vá para Aplicativos Empresariais e clique no aplicativo que precisa de solução de problemas.
  2. Navegue até a página Logon único usando o menu de navegação à esquerda
  3. Clique em Testar este aplicativo para usar a funcionalidade Testar SSO.
  4. Copie e cole o erro recebido na seção Resolução de erros e clique em Obter orientação de resolução
  5. Siga as etapas para solucionar o erro AADSTS750054

Mais informações

Para obter uma lista completa de códigos de erro de autenticação e autorização do Active Directory, consulte Códigos de erro de autenticação e autorização do Microsoft Entra

Entre em contato conosco para obter ajuda

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