Ocorre um erro de privilégio ou permissão no Microsoft Dynamics 365 App for Outlook
Este artigo ajuda a resolver erros que ocorrem quando você tenta usar ou abrir o Microsoft Dynamics 365 App for Outlook.
Aplica-se a: Dynamics 365 App for Outlook
Número original do KB: 4563997, 4229661
Sintoma 1
Ao tentar usar o Dynamics 365 App for Outlook, você recebe um erro semelhante ao seguinte:
Você não tem o privilégio necessário (prvReadOrganization), o que limita determinadas funcionalidades. Entre em contato com o administrador para obter o acesso necessário.
Motivo
Esse erro ocorrerá se o usuário associado ao registro da caixa de correio não tiver privilégios suficientes para usar o Dynamics 365 App for Outlook.
Sintoma 2
Ao abrir o Dynamics 365 App for Outlook, você recebe o seguinte erro:
Sentimos muito
Não é possível mostrar o Dynamics 365 App for Outlook porque a função de usuário atual não tem as permissões necessárias. Entre em contato com o administrador para que o direito de acesso necessário seja atribuído à solução Dynamics 365 App for Outlook.
Se você selecionar Mostrar mais, os detalhes adicionais incluirão as seguintes informações:
Erro: não tem permissões para recuperar a ID do AppforOutlookModule
Trace: Erro: Não tenho permissões para recuperar o ID do AppforOutlookModule no novo ...
Motivo
Esse erro ocorrerá se o direito de acesso do Dynamics 365 não tiver acesso ao módulo de aplicativo usado pelo Dynamics 365 App for Outlook.
Solução
Para resolver esses problemas, use uma das opções a seguir.
Opção 1: Atribuir o direito de acesso "Usuário do Dynamics 365 App for Outlook"
O direito de acesso Usuário do Dynamics 365 App for Outlook pode ser atribuído a usuários que precisam usar o Dynamics 365 App for Outlook. Esse direito de acesso está disponível na compilação 9.1.0.4206 ou posterior. Essa opção garante que os usuários tenham os privilégios básicos necessários para acessar o Dynamics 365 App for Outlook.
Opção 2: Atribuir privilégios a um direito de acesso personalizado
Se você preferir personalizar um direito de acesso para incluir os privilégios necessários, consulte a seção Mais informações para obter uma lista de privilégios necessários para usar o Dynamics 365 App for Outlook.
Importante
Os direitos de acesso personalizados não têm acesso ao módulo de aplicativo do Dynamics 365 por padrão. As etapas fornecidas na Etapa 3: Fornecer acesso ao direito de acesso também são necessárias.
Mais informações
A tabela a seguir lista os privilégios necessários para usar o Dynamics 365 App for Outlook e a guia em um direito de acesso em que o privilégio pode ser encontrado.
Um usuário com a função de Administrador do Sistema pode localizar e modificar um direito de acesso navegando até Configurações>Direitos de Acesso de Segurança>.
Para exibir quais funções são atribuídas a um usuário específico, navegue até Configurações, selecione Segurança, selecione Usuários, selecione o registro de usuário específico e, em seguida, selecione Gerenciar funções.
Nome do privilégio | Entidade | Localização (guia) no direito de acesso |
---|---|---|
prvReadEmailServerProfile | EmailServerProfile | Gestão de Negócios |
prvReadRole | Direito de Acesso | Gestão de Negócios |
prvReadUser | Usuário | Gestão de Negócios |
prvWriteMailbox | Caixa de correio | Gestão de Negócios |
prvReadMailbox | Caixa de correio | Gestão de Negócios |
prvReadOrganization | Organização | Gestão de Negócios |
prvSyncToOutlook (exchangesyncidmapping) | Sincronizar com o Outlook | Gestão de negócios > Privilégios relacionados à privacidade |
prvUseOfficeApps | Usar o Dynamics 365 App for Outlook | Gestão de negócios > Privilégios relacionados à privacidade |
prvAppendToAccount | do GitHub | Registros Principais |
prvReadAccount | do GitHub | Registros Principais |
prvDeleteActivity | Atividade | Registros Principais |
prvAppendActivity | Atividade | Registros Principais |
prvWriteActivity | Atividade | Registros Principais |
prvCreateActivity | Atividade | Registros Principais |
prvReadActivity | Atividade | Registros Principais |
prvAppendToActivity | Atividade | Registros Principais |
prvShareActivity | Atividade | Registros Principais |
prvAppendToContact | Contato | Registros Principais |
prvReadContact | Contato | Registros Principais |
prvCreateContact | Contato | Registros Principais |
prvReadUserQuery | Exibição Salva | Registros Principais |
prvReadAppModule | Aplicativo baseado em modelo | Personalização |
prvReadAttribute | Campo | Personalização |
prvReadEntity | Entidade | Personalização |
prvReadRelationship | Relacionamento | Personalização |
prvReadSystemApplicationMetadata | Metadados do Aplicativo do Sistema | Personalização |
prvReadSystemForm | Formulário do Sistema | Personalização |
prvReadUserApplicationMetadata | Metadados do Aplicativo do Usuário | Personalização |
prvReadQuery | Exibir | Personalização |
prvReadWebResource | Recurso da Web | Personalização |
prvSearchAvailability | Pesquisar Disponibilidade | Gestão de Serviços > Privilégios diversos |
A tabela a seguir lista os privilégios adicionais necessários para exibir algumas das exibições padrão usadas nos formulários do Dynamics 365 App for Outlook. Sem esses privilégios, um usuário pode ver o seguinte erro em vez da exibição esperada (subgrade) de registros:
Você não tem permissão para acessar esses registros. Entre em contato com o administrador do Microsoft Dynamics 365 para obter ajuda.
Nome do privilégio | Entidade | Localização (guia) no direito de acesso |
---|---|---|
prvReadIncident | Caso | Serviço |
prvReadOpportunity | Exemplo de | Registros Principais |
prvReadCompetitor | Concorrente | Vendas |
prvReadConnection | Conexão | Registros Principais |