Partilhar via


O erro de código de erro 80040203 (Argumento Inválido) ocorre quando você tenta importar uma solução para o Microsoft Dynamics 365

Este artigo fornece uma solução para um erro que ocorre quando você tenta importar uma solução para o Microsoft Dynamics 365.

Aplica-se a: Microsoft Dynamics 365 Customer Engagement Online
Número original do KB: 4514229

Sintomas

Ao tentar importar uma solução no Dynamics 365, você recebe a seguinte mensagem de erro:

"Falha na importação da solução: <Nome> da solução.
Código de erro 80040203."

Observação

Esse código de erro está documentado em Códigos de erro do serviço Web com as seguintes informações:

Nome: InvalidArgument
Hex: 80040203
Número: -2147220989
Argumento inválido.

Causa

Esse erro pode ser causado por vários motivos. Se a caixa de diálogo de erro fizer referência ao seguinte tipo de objeto, examine o restante deste artigo para obter uma possível solução:

Tipo: Relacionamento
Nome: Nome bpf_<entity>_<publisher>_<BPF>

Baixe o arquivo de log que, quando aberto na página Componentes, mostrará:

ItemType: Relacionamento de entidade
Nome: Nome bpf_<entity>_<publisher>_<BPF>
Código de erro: 0x80040203
ErrorText: Nome de exibição do atributo para id: <GUID>, objectcolumn: DisplayName e labelTypeCode: Atributo não especificado

O Nome do Relacionamento de Entidade será a concatenação de uma Entidade e um Fluxo de Processo de Negócios (BPF). A Entidade foi removida anteriormente de um estágio BPF e substituída por uma Entidade diferente e, em seguida, o BPF foi atualizado enquanto ainda estava ativado. A entidade foi removida do BPF, mas a relação ainda existe no esquema. Portanto, ele é exportado com a solução da fonte. Essa relação está fazendo com que o erro seja exibido.

Solução

A Microsoft está ciente desse problema e está trabalhando em uma alteração para remover essa relação após uma exclusão e atualização.

Há duas soluções alternativas para esse problema:

Opção 1 - Atualizar arquivo de solução

Se você precisar importar a solução e não puder recriar o pacote de solução, remova a relação da solução.

  1. Descompacte a solução.

  2. Edite o customization.xml.

  3. Procure o relacionamento mencionado no erro: bpf_<entity>_<publisher>_<BPF Name>

  4. Exclua todo o XML do EntityRelationship:

    <EntityRelationship Name="bpf_<entity>_<publisher>_<BPF Name>">
    ...
    </EntityRelationship>
    
  5. Salve o arquivo.

  6. Compacte todo o diretório.

  7. Importe a solução novamente.

Opção 2 – Remover a relação da origem e recriar sua solução

É uma resolução de longo prazo e corrigirá o problema para a próxima exportação da solução.

  1. Abra a organização de origem.

  2. Selecione Configurações / Personalizações / Personalize o sistema

  3. Selecione a Entidade na relação:

    bpf_<entity>_<publisher>_<BPF Name>
    
  4. Expanda os relacionamentos 1:N.

  5. Localize a relação:

    bpf_<entity>_<publisher>_<BPF Name>
    
  6. Selecione e exclua a relação.

  7. Publique todas as personalizações.

  8. Exporte a solução e importe-a para o destino.