Problemas de permissão na migração para a nuvem do Business Central
Este artigo resolve erros de permissão que você pode encontrar ao tentar configurar a migração para a nuvem no Business Central.
Sintomas
Quando um usuário executa o guia de configuração assistida da Configuração de Migração na Nuvem, uma das seguintes mensagens de erro é exibida:
- Falha na operação no NotifyBusinessCentral de destino: falha na chamada da atividade da Web com HttpStatusCode - '500': um usuário que configura a migração para a nuvem não tem permissões suficientes: não é um administrador delegado ou um administrador delegado sem o consentimento do cliente.
- Você não tem permissão para criar ou executar tarefas agendadas.
Motivo
O usuário que executa a configuração de migração para a nuvem não tem permissões suficientes.
Resolução
Observação
Para resolver esse problema, você precisa de permissões de administrador no Business Central.
- Certifique-se de que o usuário que executa a configuração tenha recebido a permissão SUPER definida no Business Central online.
- Se o usuário que executa a instalação for um administrador delegado, verifique se o cliente consentiu.