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O erros "acesso negado" ou "precisa de permissão para aceder a este site" no SharePoint Online e no OneDrive

Sintomas

Quando os utilizadores tentam aceder ao SharePoint Online ou ao site do OneDrive para Empresas, podem receber uma das seguintes mensagens de erro:

  • Acesso Negado
  • Precisa de permissão para aceder a este site
  • Utilizador não encontrado no diretório

Quando os utilizadores tentam aceder a ligações de ficheiros ou pastas que são partilhados por outros utilizadores a partir de sites do SharePoint Online ou do OneDrive, recebem a seguinte mensagem de erro:

Não tem acesso a esta ligação.
Pedimos desculpa, mas atualmente tem sessão iniciada, mas essa conta não está na lista de pessoas às quais o site está protegido. Para experimentar um e-mail diferente, termine sessão e abra novamente a ligação.

Motivo

Estes erros podem ocorrer por vários motivos, tais como:

  • As permissões para o utilizador afetado não estão configuradas corretamente.
  • A conta utilizada para aceder à ligação partilhada é diferente da conta para a qual o convite de partilha foi enviado.
  • Erro de correspondência do ID de utilizador do site. Normalmente, o erro de correspondência de ID ocorre se uma conta de utilizador for eliminada do centro de administração do Microsoft 365 e, em seguida, uma nova conta for criada com o nome principal de utilizador (UPN) que foi utilizado pela conta eliminada. É atribuído um novo valor de ID à nova conta, mesmo que o UPN seja o mesmo. O erro de correspondência também pode ocorrer durante a sincronização de diretórios entre uma unidade organizacional (UO) do Active Directory e o SharePoint se os utilizadores já tiverem iniciado sessão no SharePoint e forem posteriormente movidos para uma UO diferente.

Opção de resolução 1: executar o diagnóstico de Verificação do Acesso do Utilizador

Note

Este diagnóstico não está disponível para os ambientes GCC High ou DoD ou para o Microsoft 365 operado pela 21Vianet.

Os administradores do Microsoft 365 podem executar diagnósticos no inquilino para identificar possíveis problemas que afetam o acesso do utilizador.

Selecione o seguinte botão Executar Testes para preencher o diagnóstico no centro de administração do Microsoft 365.

O diagnóstico efetua uma grande variedade de verificações para utilizadores ou convidados internos que tentam aceder aos sites do SharePoint e do OneDrive.

Opção de resolução 2: correção manual

Para corrigir os problemas de acesso manualmente, siga os passos para o cenário relevante.

Um utilizador não consegue aceder a um site do SharePoint ou ao site do OneDrive de outro utilizador

  1. Determine o nível de permissão que o utilizador deve ter no site.

  2. Verifique a permissão com a funcionalidade Verificar Permissões:

    1. Para um site do SharePoint, selecione Configurações> Permissões do site. Para um site do OneDrive, selecione Configurações> Configurações Configurações>Permissões do site.
    2. No friso, selecione Verificar Permissões.
    3. No campo Utilizador/Grupo, introduza o nome do utilizador e, em seguida, selecione Verificar Agora.
    4. Reveja as permissões que o utilizador tem no site e e verifique o grupo de segurança (se aplicável).
  3. Se o utilizador não tiver as permissões adequadas, conceda ao utilizador permissões para o ficheiro ou site.

  4. Se o utilizador continuar a receber uma mensagem de erro, remova o utilizador do site. Em seguida, conceda as permissões ao utilizador para o ficheiro ou site.

    Nota: Se a conta de convidado continuar a ter erros, recomendamos que elimine a conta de convidado do centro de administração do Microsoft 365 completamente. Certifique-se de que o utilizador é removido da coleção de sites. Em seguida, conceda as permissões ao utilizador para o ficheiro ou site.

Um utilizador não consegue aceder ao seu próprio site do OneDrive

Normalmente, este problema é causado por um erro de correspondência do ID de utilizador do site.

Para corrigir o problema, verifique se existe um novo UPN. Se existir, elimine o novo UPN e, em seguida, restaure o UPN original.

Se não estiver familiarizado com a utilização deste procedimento, consulte Corrigir erros de correspondência do ID de utilizador do site no SharePoint ou no OneDrive para obter uma solução automatizada para corrigir o problema.

Remova o utilizador afetado do site e, em seguida, partilhe novamente o ficheiro ou pasta.