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A pesquisa híbrida falha ao pesquisar ou devolver resultados

Sintomas

Ocorre um ou mais dos seguintes problemas quando utiliza a pesquisa híbrida no SharePoint no Microsoft 365:

  • A pesquisa falha.
  • Não é devolvido nenhum resultado.
  • Recebe uma mensagem de erro, como "Uma ligação existente foi forçada a fechar".

Causa

Começámos a descontinuar o TLS 1.1 e 1.0 no Microsoft 365. A partir de 30 de junho de 2021, o Serviço de pesquisa deixará de aceitar ligações que utilizem o TLS 1.1 ou 1.0. Se estiver a utilizar a aplicação cloud Serviço de pesquisa (SSA) em versões mais antigas do Windows, tem de ativar manualmente o TLS 1.2 para ter conteúdo no local indexado no SharePoint no Microsoft 365.

Resolução

Para corrigir este problema, ative o TLS 1.2 ao seguir estas instruções:

Nota

Se continuar a ter estes problemas no Windows Server 2012 ou no Windows Server 2008 R2 SP1, experimente as seguintes soluções:

Além disso, verifique os conjuntos de cifras suportados e a sequência de ordenação do conjunto de cifras. Para o TLS 1.2, os seguintes conjuntos de cifras são suportados pelo Azure Front Door:

  • TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
  • TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
  • TLS_DHE_RSA_WITH_AES_256_GCM_SHA384
  • TLS_DHE_RSA_WITH_AES_128_GCM_SHA256

Para adicionar conjuntos de cifras, implemente uma definição de Política de Grupo ou utilize a Política de Grupo Revisor Local, conforme descrito em Configurar a Ordem do Conjunto de Cifras TLS com Política de Grupo.

Importante

Altere a ordem dos conjuntos de cifras para se certificar de que estes quatro conjuntos estão no topo da lista (a prioridade mais alta).

Para obter mais informações, consulte Quais são os conjuntos de cifras suportados atualmente pelo Azure Front Door?.

Referências

Ainda necessita de ajuda? Vá a Comunidade SharePoint