O Office 2013 não consegue fazer check-in de arquivos quando a LAN não tem acesso à Internet ou em algumas VPNs
Este artigo foi escrito por Warren Rath, engenheiro de escalonamento de suporte.
Nos casos em que a VPN causa esse problema, encontramos um problema no código do Windows (113100710844135), a correção está fora Cliente VPN de terceiros interrompe a conectividade com a Internet no Windows 7 SP1 ou Windows Server 2008 R2 SP1. Verificamos que o Palo Alto Networks, o Global Protect Client e o Juniper VPN funcionam com essa correção.
Os clientes estão usando soluções VPN de terceiros no Windows 7. Se os clientes migrarem para o Office 2013 a partir de uma versão mais antiga do Office, poderão sofrer perda de funcionalidade no Office quando conectados via VPN. O Office 2013 dependia do NLA (Network Location Awareness) e algumas soluções VPN não funcionam corretamente com o NLA. Especificamente, se o software VPN não definir um gateway padrão. Nesse caso, o NLA sempre informará que o cliente não está conectado à Internet. Isso afeta o Office 2013, pois depende da conectividade com a Internet para algumas funções. Por exemplo, não há nenhum arquivo de ajuda na máquina e toda a ajuda está na Internet. Se um cliente pressionar F1 em um aplicativo do Office 2013, ele sempre receberá um erro dizendo que não está conectado à Internet enquanto estiver conectado via VPN.
Sintomas
Os usuários sem acesso total à Internet podem não conseguir fazer check-in de arquivos do cliente do Office 2013, mesmo que haja uma boa conexão entre o cliente do Office e o servidor do SharePoint.
Motivo
Houve uma mudança de design entre o Office 2010 e 2013, onde 2013 agora requer uma conexão com a Internet para algumas atividades. Alguns clientes já se queixaram deste problema e o grupo de produtos foi informado das limitações de conceção. (Mas nenhum hotfix está atualmente em andamento, um hotfix pode não ser possível, isso parece ser uma alteração significativa)
A raiz do problema parece ser que o Office 2013 tem uma dependência do NLA (Network Location Awareness). O NLA usa testes para determinar se a conexão de rede tem "Acesso à Internet". A forma como isso é feito são de duas maneiras.
- Ele faz uma sonda DNS para
dns.msftncsi.com
. Espera uma resposta específica. A resposta deve ser131.107.255.255
. Se for, então essa é a sonda DNS correta. - Ele tenta se conectar e
https://www.msftncsi.com
tenta recuperar o arquivo ncsi.txt. Dentro do arquivo, o texto deve ser "Microsoft NCSI".
Se ambas as condições acima forem atendidas, a conexão será marcada como tendo conectividade com a Internet, se não a conexão estiver marcada como não tendo conectividade com a Internet e alguns recursos do Office não funcionarão.
Solução
É possível configurar um servidor NCIS local (Network Connection Status Indicator) na sua LAN que responderá à solicitação dos Clientes do Office e permitirá que o recurso do Office funcione.
Veja o post abaixo para obter informações e instruções relacionadas: