As credenciais não funcionam para conteúdo protegido por IRM
Sintomas
Quando tenta abrir um documento, livro, mensagem de e-mail ou outro item protegidos pela Gestão de Direitos de Informação (IRM), descobre que não tem acesso ao item, apesar de ter iniciado sessão corretamente no Microsoft Office. Além disso, é-lhe pedido para iniciar sessão, mas continua a não conseguir aceder ao conteúdo quando deverá conseguir aceder ao mesmo.
Normalmente, este sintoma é que lhe é pedido para iniciar sessão, mas as suas credenciais não funcionam.
Causa
Este comportamento ocorre quando as seguintes condições são verdadeiras:
- O seu ambiente está configurado para autenticação entre domínios.
- O domínio onde o conteúdo é criado está configurado para ter requisitos de Acesso Condicional.
- A autenticação falha.
Por exemplo, John@contoso.com protege o conteúdo e envia-o para Jenny@fabrikam.com. Para aceder ao conteúdo protegido, Jenny@fabrikam.com tem de se autenticar no contoso.com para obter a chave para desencriptar o conteúdo. Se contoso.com tiver requisitos de Acesso Condicional, esta autenticação poderá falhar.
A maioria dos desafios do Acesso Condicional exige que o utilizador seja aprovisionado no inquilino do recurso (contoso.com). Se o utilizador convidado (Jenny@fabrikam.com) for explicitamente convidado e o convite for resgatado, Jenny@fabrikam.com será aprovisionado no inquilino do recurso contoso.com. Se o utilizador for um utilizador pass-through, o código de validação de Acesso Condicional contoso.com não tem uma forma de satisfazer os desafios, pelo que o pedido falha. Este comportamento é esperado e seguro. Em muitos casos, este comportamento faz com que o código do cliente do Office peça o início de sessão para que o utilizador possa fornecer credenciais para abrir o ficheiro porque a autenticação falhou.
Referência
Para obter mais informações sobre as políticas de Acesso Condicional, consulte o seguinte blogue:
Políticas de Acesso Condicional para Information Protection do Azure