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Solucionar problemas comuns no AKS Edge Essentials

Este artigo descreve como encontrar soluções para problemas encontrados ao usar o AKS Edge Essentials. Os problemas e erros conhecidos são organizados por área funcional. Você pode usar os links fornecidos neste artigo para encontrar soluções e soluções alternativas para resolvê-las.

Abrir um pedido de suporte

Consulte o artigo Obter suporte para obter informações sobre como usar o portal do Azure para obter suporte ou abrir uma solicitação de suporte para o AKS Edge Essentials.

Problemas de implementação

Problema de editor não confiável

Mensagem de erro: "Pretende executar software deste editor não fidedigno? ....."

Solução alternativa: atualize sua política de execução do PowerShell para RemoteSigned:

# Get the execution policy on the system
Get-ExecutionPolicy
# Set the execution policy for this process only
if ((Get-ExecutionPolicy) -ne "RemoteSigned") { Set-ExecutionPolicy -ExecutionPolicy RemoteSigned -Scope Process -Force }

O pouco espaço em disco faz com que imagens de contêiner armazenadas em cache anteriormente sejam excluídas

Quando o nó fica sem espaço em disco, algumas das imagens pré-carregadas são lixo coletado containerd pelo tempo de execução. Nesse caso, primeiro libere algum espaço em disco e, em seguida, execute o seguinte comando para extrair as imagens armazenadas em cache novamente:

    Invoke-AksEdgeNodeCommand -NodeType Linux -command "sudo /path/to/script/reimport-ci.sh

Este script verifica as imagens em falta e reimporta-as conforme necessário.

Conectividade do Azure Arc

  1. Problema: Disconnect-AksEdgeArc não remove os pods do cluster.

    Solução alternativa: se os pods não forem limpos, execute os seguintes comandos para limpar manualmente os recursos existentes relacionados ao Azure Arc antes de tentar se reconectar novamente:

    kubectl delete ns azure-arc
    kubectl delete clusterrolebinding azure-arc-operator
    kubectl delete secret sh.helm.release.v1.azure-arc.v1
    
  2. Problema: a conectividade do Azure Arc não funciona em um ambiente de proxy.

    Solução alternativa: Você pode habilitar as configurações de proxy em todo o sistema seguindo as opções > da Internet Configurações de LAN de conexões>.

    Captura de ecrã a mostrar as opções da Internet.

Implantações offline

Falha ao obter o certificado nodeagent: Não encontrado

Verifique a configuração do adaptador de rede. Durante a implantação, o AKS Edge Essentials precisa de um adaptador habilitado e com o endereço IP, a sub-rede e o gateway padrão corretos. Esses valores são preenchidos automaticamente em um ambiente DHCP. Se estiver a definir manualmente, certifique-se de que os três estão definidos. Em muitos casos, o gateway padrão não está definido, o que resulta nesse erro.

Kubernetes

Kube-vip pod reinicia continuamente

Em alguns cenários, o pod kube-vip faz loops e reinicia continuamente.

Validação

Para confirmar que o cenário que você está encontrando é o mesmo problema documentado neste artigo, verifique se o pod kube-vip no namespace kube-system tem um alto número de reinicializações executando o seguinte comando:

kubectl get pods –n kube-system

Motivo

Existem algumas razões diferentes pelas quais o pod kube-vip pode estar constantemente reiniciando. Estas causas incluem:

Resolução

Para atenuar esse problema, revise sua infraestrutura de armazenamento subjacente para garantir que ela atenda aos requisitos de desempenho do etcd e do AKS Edge Essentials. Além disso, considere o uso de armazenamento premium apoiado por SSD ou a otimização da configuração de armazenamento para desempenho.

Próximos passos

Visão geral do AKS Edge Essentials