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NZDST - Issue after installing KB933819 on Sharepoint with PSConfigui.exe

Hi All,

 

Here's a recent support case on Sharepoint that maybe useful to you. 

 

ISSUE:

====================

After installing a hot fix 933819 customer is running the SharePoint Products and
Technologies Configuration wizard (PSConfigui.exe) wizard to upgrade the
databases
The PSConfigui.exe wizard is failing at step 4

ERROR MESSAGE:
====================
08/03/2007 12:52:09 8 ERR An exception of type
Microsoft.SharePoint.Administration.SPUpdatedConcurrencyException was thrown.
Additional exception information: An update conflict has occurred, and you must
re-try this action. The object DiagnosticsService Parent=SPFarm
Name=SharePoint_Config is being updated by Domain\User, in the w3wp process, on
machine SERVER. View the tracing log for more information about the conflict.
Microsoft.SharePoint.Administration.SPUpdatedConcurrencyException: An update
conflict has occurred, and you must re-try this action. The object
DiagnosticsService Parent=SPFarm Name=SharePoint_Config is being updated by
Domain\User, in the w3wp process, on machine SERVER. View the tracing log for more
information about the conflict.

CAUSE:
====================
The SharePoint Config Wizard was not able to update the SharePoint databases due to
a lock on the SPFarm object, resulting in the SharePoint config wizard to fail.

RESOLUTION/WORKAROUND:
====================
Force SharePoint to refresh its local config cache, and re-run the SharePoint
Products and Technologies Configuration wizard. It then completes without error.

To reset the config cache:
1. On the SharePoint Server where Central Administration Site is hosted browse to
C:\Documents and Settings\All Users\Application
Data\Microsoft\SharePoint\Config\<guid>
2. Take a backup of cache.ini file. Then Edit the cache.ini and replace the current
value with "1".
3. Restart the Windows SharePoint Services Timer service.
4. Verify the cache.ini now contains its previous value.
5. Run the SharePoint Products and Technologies Configuration wizard again

If the SharePoint Products and Technologies Configuration wizard fails again with
the same error but shows a different "Username" in the error. Repeat the above
steps again.

Nick.

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