Problemas com servidores de região no Azure HDInsight
Este artigo descreve as etapas de solução de problemas e possíveis resoluções para problemas ao interagir com clusters do Azure HDInsight.
Cenário: regiões não atribuídas
Problema
Ao executar hbase hbck
o comando, você verá uma mensagem de erro semelhante a:
multiple regions being unassigned or holes in the chain of regions
Na interface do usuário do Apache HBase Master, você pode ver o número de regiões desequilibradas em todos os servidores de região. Em seguida, você pode executar hbase hbck
o comando para ver buracos na cadeia de região.
Motivo
Os buracos podem ser o resultado de regiões offline.
Resolução
Corrija as atribuições. Siga as etapas abaixo para trazer as regiões não atribuídas de volta ao estado normal:
Entre no cluster HBase do HDInsight usando SSH.
Execute
hbase zkcli
o comando para se conectar ao shell do ZooKeeper.Executar
rmr /hbase/regions-in-transition
ourmr /hbase-unsecure/regions-in-transition
comando.Saia do shell do zookeeper usando o
exit
comando.Abra a interface do usuário do Apache Ambari e reinicie o serviço Ative HBase Master.
Execute o
hbase hbck
comando novamente (sem mais opções). Verifique a saída e verifique se todas as regiões estão sendo atribuídas.
Cenário: Servidores de região inativa
Problema
Os servidores da região não são iniciados.
Motivo
Vários diretórios WAL de divisão.
Obter lista de WALs atuais:
hadoop fs -ls -R /hbase/WALs/ > /tmp/wals.out
.Inspecione o
wals.out
arquivo. Se houver muitos diretórios de divisão (começando com *-splitting), o servidor de região provavelmente está falhando por causa desses diretórios.
Resolução
Pare o HBase do portal Ambari.
Execute
hadoop fs -ls -R /hbase/WALs/ > /tmp/wals.out
para obter uma nova lista de WALs.Mova os diretórios *-splitting para uma pasta
splitWAL
temporária e exclua os diretórios *-splitting.Execute
hbase zkcli
o comando para se conectar com o shell do zookeeper.Executar
rmr /hbase-unsecure/splitWAL
.Reinicie o serviço HBase.
Próximos passos
Se não viu o problema ou não conseguiu resolvê-lo, visite um dos seguintes canais para obter mais suporte:
Obtenha respostas de especialistas do Azure através do Suporte da Comunidade do Azure.
Conecte-se com o @AzureSupport - a conta oficial do Microsoft Azure para melhorar a experiência do cliente. Ligar a comunidade do Azure aos recursos certos: respostas, suporte e especialistas.
Se precisar de mais ajuda, você pode enviar uma solicitação de suporte do portal do Azure. Selecione Suporte na barra de menus ou abra o hub Ajuda + suporte . Para obter informações mais detalhadas, consulte Como criar uma solicitação de suporte do Azure. O acesso ao suporte para Gestão de Subscrições e faturação está incluído na sua subscrição do Microsoft Azure e o Suporte Técnico é disponibilizado através de um dos Planos de Suporte do Azure.