Partilhar via


Cenário: Tempos limite com o comando 'hbase hbck' no Azure HDInsight

Este artigo descreve as etapas de solução de problemas e possíveis resoluções para problemas ao interagir com clusters do Azure HDInsight.

Problema

Encontre tempos limite com hbase hbck comando ao corrigir atribuições de região.

Motivo

Uma causa potencial para problemas de tempo limite quando você usa o hbck comando pode ser que várias regiões estão no estado "em transição" por um longo tempo. Você pode ver essas regiões como offline na interface do usuário do HBase Master. Como um grande número de regiões está tentando fazer a transição, o HBase Master pode atingir o tempo limite e não conseguir colocar essas regiões online novamente.

Resolução

  1. Entre no cluster HBase do HDInsight usando SSH.

  2. Execute hbase zkcli o comando para se conectar ao shell do Apache ZooKeeper.

  3. Executar rmr /hbase/regions-in-transition ou rmr /hbase-unsecure/regions-in-transition comando.

  4. Saia do hbase zkcli shell usando exit o comando.

  5. Na interface do usuário do Apache Ambari, reinicie o serviço Ative HBase Master.

  6. Execute o comando hbase hbck -fixAssignments.

  7. Monitore a "região em transição" da interface do usuário do HBase Master para garantir que nenhuma região fique presa.

Próximos passos

Se não viu o problema ou não conseguiu resolvê-lo, visite um dos seguintes canais para obter mais suporte:

  • Obtenha respostas de especialistas do Azure através do Suporte da Comunidade do Azure.

  • Conecte-se com o @AzureSupport - a conta oficial do Microsoft Azure para melhorar a experiência do cliente. Ligar a comunidade do Azure aos recursos certos: respostas, suporte e especialistas.

  • Se precisar de mais ajuda, você pode enviar uma solicitação de suporte do portal do Azure. Selecione Suporte na barra de menus ou abra o hub Ajuda + suporte . Para obter informações mais detalhadas, consulte Como criar uma solicitação de suporte do Azure. O acesso ao suporte para Gestão de Subscrições e faturação está incluído na sua subscrição do Microsoft Azure e o Suporte Técnico é disponibilizado através de um dos Planos de Suporte do Azure.