Solucionar problemas de cópia de dados no Azure Data Box Disk
Este artigo aplica-se ao Microsoft Azure Data Box Disk e descreve como solucionar quaisquer problemas que você vê ao copiar os dados para discos. O artigo também aborda problemas ao usar a ferramenta de cópia dividida.
Problemas de cópia de dados ao usar um sistema Linux
Esta seção detalha alguns dos principais problemas enfrentados ao usar um cliente Linux para copiar dados para discos.
Problema: a unidade é montada como somente leitura
Motivo
Um sistema de arquivos não limpo pode resultar em unidades sendo montadas como somente leitura.
Remontar uma unidade como leitura-gravação não funciona com discos Data Box. Este cenário não é suportado com unidades desencriptadas pelo dislocker. Você pode remontar o dispositivo com êxito usando o seguinte comando:
# mount -o remount, rw /mnt/DataBoxDisk/mountVol1
Embora a remontagem tenha sido bem-sucedida, os dados não persistirão.
Resolução
Siga os seguintes passos no seu sistema Linux:
Instale o
ntfsprogs
pacote para o utilitário ntfsfix.Desmonte os pontos de montagem fornecidos para a unidade pela ferramenta de desbloqueio. O número de pontos de montagem varia consoante as unidades.
unmount /mnt/DataBoxDisk/mountVol1
Execute
ntfsfix
no caminho correspondente. O número realçado deve ser igual ao Passo 2.ntfsfix /mnt/DataBoxDisk/bitlockerVol1/dislocker-file
Execute o seguinte comando para remover os metadados de hibernação que podem causar o problema de montagem.
ntfs-3g -o remove_hiberfile /mnt/DataBoxDisk/bitlockerVol1/dislocker-file /mnt/DataBoxDisk/mountVol1
Faça uma desmontagem limpa.
./DataBoxDiskUnlock_x86_64 /unmount
Faça um desbloqueio limpo e monte.
Teste o ponto de montagem escrevendo um arquivo.
Desmonte e remonte para validar a persistência do arquivo.
Continue com a cópia de dados.
Problema: erro com dados que não persistem após a cópia
Motivo
Se a unidade não contiver os dados copiados depois de montada, é possível que tenha sido remontada como leitura-gravação depois de ter sido montada como somente leitura.
Resolução
Se for esse o caso, consulte a resolução para unidades montadas como somente leitura.
Se esse não foi o caso, copie os logs da pasta que tem a ferramenta de desbloqueio de disco Data Box e contate o suporte da Microsoft.
Erros da ferramenta de Cópia Dividida do Data Box Disk
Os problemas observados ao usar uma ferramenta de cópia dividida para dividir os dados em vários discos são resumidos na tabela a seguir.
Mensagem de erro/avisos | Recomendações |
---|---|
[Informações] Recuperando a senha do BitLocker para o volume: m [Erro] Exceção detetada ao recuperar a chave BitLocker para o volume m: A sequência não contém elementos. |
Este erro é gerado se os discos Data Box de destino estiverem offline. Utilize a ferramenta diskmgmt.msc para os discos online. |
[Erro] Exceção emitida: falha na operação de WMI: Method=UnlockWithNumericalPassword, ReturnValue=2150694965, Win32Message = o formato da palavra-passe de recuperação fornecida é inválido. As palavras-passe de recuperação do BitLocker têm 48 dígitos. Certifique-se de que a palavra-passe de recuperação está no formato correto e, em seguida, tente novamente. |
Utilize a ferramenta de Desbloqueio do Data Box Disk para desbloquear primeiro os discos e repita o comando. Para mais informações, aceda a |
[Erro] Exceção emitida: existe um ficheiro DriveManifest.xml na unidade alvo. Isto indica que a unidade alvo pode ter sido preparada com um ficheiro de diário diferente. Para adicionar mais dados à mesma unidade, utilize o ficheiro de diário anterior. Para excluir dados existentes e reutilizar a unidade de destino para um novo trabalho de importação, exclua o DriveManifest.xml na unidade. Execute novamente este comando com um novo ficheiro de diário. |
Este erro é recebido quando tenta utilizar o mesmo conjunto de unidades para várias sessões de importação. Utilize um conjunto de unidades para uma só sessão de divisão e cópia. |
[Erro] Exceção emitida: CopySessionId importdata-sept-test-1 refere-se a uma sessão de cópia anterior e não pode ser reutilizado para uma nova sessão de cópia. | Este erro é reportado quando tenta utilizar o mesmo nome de tarefa para uma nova tarefa como sendo uma tarefa anterior concluída com êxito. Atribua um nome exclusivo à nova tarefa. |
[Informações] O nome do ficheiro ou diretório de destino excede o limite de comprimento NTFS. | Esta mensagem é reportada quando o ficheiro de destino tiver sido renomeado devido ao caminho de ficheiro longo. Modifique a opção de disposição no ficheiro config.json para controlar este comportamento. |
[Erro] Exceção emitida: sequência de escape JSON inválida. | Esta mensagem é reportada quando o config.json está num formato inválido. Valide o config.json com JSONlint antes de guardar o ficheiro. |
Próximos passos
- Saiba como solucionar problemas da ferramenta de validação.