Dispositivo de áudio USB não está sendo reproduzido
Este artigo discute o erro "Serviços de áudio não estão respondendo" e o dispositivo de áudio USB não funciona no Windows 10 versão 1703.
Sintomas
Considere o cenário a seguir.
- Você conecta um dispositivo de áudio USB (Barramento Serial Universal), como um adaptador de áudio ou um DAC (conversor digital para analógico) USB, a um computador Windows pela primeira vez.
- O sistema operacional detecta o dispositivo e carrega o driver de áudio USB padrão 2.0 (usbaudio2.sys).
- Em seguida, o Windows baixa o driver específico do dispositivo de Windows Update.
- O driver de dispositivo baixado substitui o driver de usbaudio2.sys.
Nesse cenário, o dispositivo não pode ser usado e o computador não tem som. O ícone do alto-falante na barra de tarefas é marcado com uma marca X. Ao selecionar o ícone, você recebe a seguinte mensagem:
Os serviços de áudio não estão respondendo. Os serviços Windows Audio e Windows Audio End Point Builder devem estar em execução para que o áudio funcione corretamente.
Causa
Esse problema de "áudio não está sendo reproduzido" ocorre porque o driver de áudio USB padrão 2.0 (usbaudio2.sys) usa a porta WaveRT para operação, mas o driver específico do dispositivo não. No entanto, ambos os drivers usam a cadeia de referência "wave" quando a interface do dispositivo é registrada.
Quando o driver específico do dispositivo substitui o driver padrão, a interface do dispositivo criada por usbaudio2.sys ainda é usada porque as cadeias de caracteres de referência se sobrepõem. Portanto, o sistema operacional pressupõe que o novo driver também dá suporte à porta WaveRT. Como o novo driver não dá suporte à porta WaveRT, o sistema não pode acessar o driver.
Resolução
Para corrigir esse problema, use um dos métodos a seguir.
Método 1
Siga estas etapas para desinstalar o dispositivo:
- Abra o Gerenciador de Dispositivos.
- Clique duas vezes no nome do dispositivo.
- Selecione a guia Driver .
- Selecione Desinstalar dispositivo.
Observação
Não selecione a caixa Excluir o software do driver para este dispositivo marcar.
Método 2
Conecte o dispositivo a uma porta USB diferente. O problema pode não ocorrer se o dispositivo estiver conectado a uma porta USB diferente.
Método 3
Se o dispositivo ainda não estiver conectado, instale o driver específico do dispositivo primeiro usando o instalador para o dispositivo. Em seguida, conecte o dispositivo. O Windows agora seleciona o driver específico do dispositivo em vez do driver de áudio USB padrão 2.0. Esse método funciona porque o problema só ocorre se o driver específico do dispositivo substituir o driver padrão depois que o dispositivo estiver conectado.