Erro "Campo obrigatório ausente" durante importações históricas
Sintomas
Ao importar dados históricos de um arquivo .csv para o Viva Glint, você recebe uma mensagem de erro com o seguinte formato:
Erro na linha 2: ausente no campo obrigatório – [<usuário>, <respostas às perguntas> da pesquisa]
Este é um exemplo:
Erro na linha 2: ausente no campo obrigatório - [reed@contoso.com, 4, Temos uma progressão de carreira maravilhosa na organização., 4,, 3, Existem oportunidades legais de promoção na organização. Isso me deixa orgulhoso. Estou muito animado com o futuro aqui. 4,, 3,, 5, Temos um trabalho de equipe legal na organização., 5, Temos um reconhecimento fantástico na minha equipe. , 2,, 4, Há suporte energizante., 4, Temos estrutura de departamento energizante. Isso é muito importante para mim.,...]
Causa
Esse problema ocorre porque o arquivo .csv importado para o Viva Glint não tem um dos campos necessários para o Arquivo de Pontuação Bruta.
Solução
Para corrigir o problema, execute estas etapas:
- Se o arquivo de dados tiver uma extensão .csv, use o Assistente de Importação de Texto para importar os dados para o Excel, preservando-os no formato original.
- Revise as colunas necessárias para arquivos de pontuação bruta de importação histórica.
- Atualize os cabeçalhos de coluna e as colunas para corresponder aos requisitos.
- Salve o arquivo editado como .csv com codificação UTF-8 (com ou sem BOM) e carregue o arquivo novamente.