Os registros do Dataverse são criados sem campos obrigatórios
Aplica-se a: Dynamics 365 Field Service, Dataverse
Sintomas
Depois que os usuários inserem dados por meio da API Web do Microsoft Dataverse, alguns campos obrigatórios estão ausentes ou não são preenchidos nos registros criados. Por exemplo, o campo Título de Ocorrência obrigatório está em branco em uma ocorrência criada, conforme mostrado na captura de tela a seguir.
Ao abrir o caso afetado, você deve inserir um valor para o campo Título do caso.
Motivo
Esse problema ocorre se os registros forem criados a partir de uma ferramenta de terceiros, como o Postman. Essas ferramentas não verificam os campos obrigatórios. Em vez disso, eles enviam os dados como estão.
Solução alternativa
Para contornar esse problema, verifique os seguintes itens:
- Verifique se os campos obrigatórios estão incluídos nos fluxos.
- Verifique a existência de campos obrigatórios nas entidades criadas por meio de solicitações HTTP.