Você não pode acessar os recursos da empresa em um dispositivo ADE registrado no Intune
Este artigo fornece dois métodos para resolver o erro que ocorre quando você não pode acessar os recursos da empresa em um dispositivo Apple Automated Device Enrollment (ADE).
Sintomas
Você tem um dispositivo ADE registrado no Microsoft Intune e tem políticas de Acesso Condicional aplicadas. Ao tentar acessar um aplicativo de nuvem no dispositivo, você recebe a seguinte mensagem de erro:
Sua entrada foi bem-sucedida, mas seu administrador exige que seu dispositivo seja gerenciado por <CompanyName> para acessar esse recurso.
Causa
Esse problema ocorre se as seguintes condições forem verdadeiras:
- O perfil de registro tem o método de autenticação definido como Assistente de configuração.
- O aplicativo Portal da Empresa não está implantado no dispositivo ADE.
- O aplicativo Portal da Empresa é necessário para impor políticas de Acesso Condicional.
Solução 1
Defina o método de autenticação como Portal da Empresa no perfil de registro. Para fazer isso, siga estas etapas:
Entre no centro de administração Microsoft Intune, selecione Dispositivos>iOS/iPad>Tokens do Programa de Registro de Registro>do iOS/iPad.
Selecione o token, selecione Perfis, selecione o perfil de registro atribuído aos dispositivos afetados.
Na lista Método de autenticação, selecione Portal da Empresa.
Observação
Depois de alterar o método de autenticação do Assistente de Configuração para o Portal da Empresa, o Intune ignora a autenticação do usuário por meio do Assistente de Configuração do iOS e, em vez disso, usa a autenticação moderna. Isso permite que o usuário use a MFA (autenticação multifator) do Microsoft Entra. Esse método pode ser aplicado sem bloquear o registro do Apple ADE.
Solução 2
Implante o aplicativo Portal da Empresa no dispositivo. Para fazer isso, siga as etapas em Adicionar políticas de configuração de aplicativo para dispositivos iOS/iPadOS gerenciados.