A quantidade não pode ser reduzida quando uma ordem de venda é cancelada
Código de erro: SYS138831
Sintomas
O sistema mostra a seguinte mensagem de erro:
A quantidade não pode ser reduzida. O número de transações de estoque na ordem é muito baixo porque a quantidade ou parte dela é referenciada por uma ordem de saída ou uma ordem de produção ou é marcada em relação a outras transações.
Causa
Se o trabalho estiver associado a uma ordem de venda, você não poderá cancelar a ordem de venda até que o trabalho seja cancelado e revertido. Esse requisito se aplica mesmo se o trabalho associado à ordem de venda estiver fechado.
Solução
Para corrigir esse problema, conclua as seguintes tarefas:
- Cancelar trabalho aberto.
- Exclua a carga.
- Reduza a quantidade separada.
Cancelar trabalho aberto
Para cancelar o trabalho aberto, siga estas etapas.
- Acesse Gerenciamento de>depósito Tarefas periódicas>Limpar Cancelar>trabalho.
- No campo ID do Trabalho, especifique a ID do trabalho que você deseja cancelar e que atualmente tem um valor de Status do trabalho de Aberto, Em andamento, Cancelado, Combinado ou Fechado.
- Selecione OK.
- Selecione Sim para confirmar que deseja cancelar o trabalho.
Excluir a carga
Para excluir uma carga, siga estas etapas.
- Acesse Vendas e marketing>Ordens de venda>Todas as ordens de venda.
- Abra a ordem de venda relevante.
- Na Guia Rápida Linhas da ordem de venda, selecione Armazém>Detalhes do trabalho.
- Na página Trabalho , no Painel de Ação, na guia Trabalho , no grupo Trabalho , selecione Cancelar trabalho.
- Confirme se o campo Status do trabalho está definido como Cancelado.
- Feche a página Trabalho.
- Na página de detalhes da ordem de venda, na Guia Rápida Linhas da ordem de venda, selecione Detalhes da carga do depósito>.
- No Painel de Ações, selecione Excluir.
- Selecione Sim para confirmar que deseja excluir a carga.
- Feche a página Carregar .
Reduzir a quantidade separada
Depois que todo o trabalho for cancelado, siga estas etapas para reduzir a quantidade separada.
- Acesse Vendas e marketing>Ordens de venda>Todas as ordens de venda.
- Abra a ordem de venda relevante.
- Na Guia Rápida Linhas da ordem de venda, selecione Atualizar separação de linha>na barra de ferramentas.
- Na página Separar, na seção Transações, selecione a linha em que o campo Status da saída está definido como Separado.
- Na seção Transações, selecione Adicionar linha de separação na barra de ferramentas.
- Na seção Separando linhas, selecione Confirmar separação na barra de ferramentas.
- Feche a página de seleção .
- Na página de detalhes da ordem de venda, no Painel de Ação, na guia Ordem de venda, no grupo Manter , selecione Cancelar.
- Selecione Sim para confirmar que deseja cancelar a ordem de venda.