Solucionar problemas com o gráfico Pipeline de Vendas e suas fases no Dynamics 365 Sales
Este artigo ajuda você a solucionar problemas relacionados ao gráfico Pipeline de vendas e suas fases.
O gráfico Pipeline de vendas consiste nas fases do pipeline de uma oportunidade. A fase é baseada no estágio do fluxo do processo empresarial em que a oportunidade está, como 1-Qualificar, 2-Desenvolver e assim por diante. Para obter mais informações, consulte Entender o gráfico de pipeline de vendas e suas fases.
Problema 1 - Várias fases do pipeline com sequências diferentes, como 6-Close e 7-Close
Causa
Esse problema pode ocorrer se você tiver alterado a sequência de uma opção de categoria de estágio (por exemplo, você alterou Fechar de 6 para 7). As oportunidades existentes que foram movidas para o estágio Fechar antes de você fazer essa alteração continuarão a mostrar o mesmo valor de fase do funil que foi definido quando foram movidas para o estágio Fechamento . No entanto, as oportunidades que forem movidas para o estágio Fechar depois que você fizer essa alteração usarão a nova sequência para o estágio Fechar .
Solução
Você pode resolver esse problema redefinindo os valores de oportunidades mais antigas alterando o estágio do fluxo do processo empresarial para algum outro estágio e, em seguida, trazendo-o de volta para o estágio Fechar ou atualizando o atributo stepname da oportunidade programaticamente.
Problema 2 - Valores de fase do pipeline de várias definições de fluxo do processo empresarial
Causa
Isso é esperado se você usar várias definições de fluxo do processo empresarial para a entidade Oportunidade. O atributo de fase de pipeline pronto para uso é definido em cada alteração de estágio no fluxo do processo empresarial do registro Oportunidade, independentemente de quantos fluxos do processo empresarial estão associados a esse registro.
Solução
Se você tiver vários fluxos do processo empresarial, considere adicionar um campo personalizado ao Processo de Vendas de Oportunidade e definir seu valor programaticamente para as alterações de estágio necessárias no fluxo do processo empresarial para a oportunidade.
Problema 3 – A ordenação do gráfico de pipeline de vendas é exibida de forma diferente na Interface Unificada em comparação com o cliente Web herdado
O cliente Web herdado exibe o gráfico usando o valor da opção de categoria associada, enquanto na Interface Unificada os estágios são exibidos em ordem alfabética. Como as fases do pipeline são prefixadas com a ordem definida no conjunto de opções de categoria Estágio, elas são exibidas de acordo com a sequência de opções de categoria (1, 2 e assim por diante).
Problema 4 - Os estágios não são classificados numericamente quando o número de estágios está além de 9
Causa
Os gráficos na Interface Unificada são classificados em ordem alfabética. Quando você tem estágios de vendas além de 9 (por exemplo: 10-OnHold, 11-Pipeline), esses estágios aparecem no gráfico antes de qualquer estágio que comece com 2. Em outras palavras, o gráfico renderiza todas as fases com o primeiro caractere como 1 e, em seguida, exibe as fases que começam com 2 e assim por diante.
Solução
Para resolver esse problema, você deve configurar um atributo/coluna personalizado e preenchê-lo com base nos requisitos do gráfico. Para obter mais informações, consulte Como criar e editar colunas.