A instalação da solução falha devido a dependências que não existem em um ambiente CDS
Este artigo fornece uma solução para um problema em que a instalação da solução falha devido a dependências que não existem em um ambiente CDS.
Aplica-se a: Microsoft Dynamics 365
Número original do KB: 4499731
Sintomas
Quando você tenta importar uma solução no Dynamics 365, a importação falha devido a dependências ausentes. Se você estiver instalando a solução do centro de administração, poderá ver apenas uma mensagem indicando que a instalação falhou. Se você estiver importando uma solução do aplicativo Web do Dynamics 365, poderá ver mais detalhes, como quais dependências estão ausentes.
Causa
Isso pode ocorrer se a solução exigir componentes que não existem em um ambiente CDS (Common Data Service). Um ambiente somente CDS não tem todas as entidades incluídas e inclui apenas algumas entidades padrão. Se a solução que você está tentando instalar depender de uma entidade que não existe em seu ambiente (por exemplo, uma entidade que só existe no aplicativo de vendas), a solução não será instalada com êxito.
Solução
Tente instalar a solução apenas em um ambiente que inclua os componentes necessários. Há muitas soluções que podem ser encontradas no Centro de Administração e no AppSource que só podem ser instaladas se você tiver determinadas licenças, como uma licença que inclui o aplicativo Vendas.